Docker: Error response from daemon: Unknown runtime specified nvidia

Just flashed NVIDIA Jetson Linux L4T 32.7.1 to my Jetson Nano, pulled docker with sudo docker pull

Running docker
sudo docker run -it --rm --runtime nvidia --network host

leads to: docker: Error response from daemon: Unknown runtime specified nvidia.

Running docker without --runtime nvidia works, but seems to have no access to GPU (python3 ; import tensorflow leads to Could not load dynamic library ‘’)

Thanks for help

It looks similar to:
Docker isn't working after apt upgrade - #7 by harrison-matt

Please take a look and give it a try.

May also try docker for deepstream:
Install nvidia container runtime with docker intergration in jetson nano emmc (16gb) - #7 by AastaLLL

thanks a lot for your help. I tried it, and

  • the first hint did not help
  • the second (changing path in /etc/docker/daemon.json) helped finding –runtime nvidia

sudo docker run -it --rm --runtime nvidia --network host
started without problems. But tensorflow could still not be imported due to the missing library I searched for it manually in the container, could not locate it either.


The container of JetPack 4 is mounted CUDA-related library from the Jetson device.
So you will need to install the JetPack components to get the CUDA library.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.