JetPack 4.5.1 docker runtime=nvidia

when I run docker run --runtime nvidia

sonme error happened, as you see.

docker: Error response from daemon: Unknown runtime specified nvidia.

when i set override.conf and daemon.json

docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container punning prestart hook 1 caused \“error running hook: exit status 1, stdout: , stderr: exec command: [/usr/vice=all --compute --compat32 --graphics --utility --video --display --pid=19698 /var/lib/docker/overlay2/1ontainer-cli: mount error: file creation failed: /var/lib/docker/overlay2/ file exists\\n\”"": unknown.


Please noted that docker is pre-included in the JetPack software.
You don’t need to install it manually.

We have double-checked the docker run command on JetPack4.5.1, and it can works correctly.
Could you try the same command to see if it also works?

$ sudo docker run -it --rm --net=host --runtime nvidia  -e DISPLAY=$DISPLAY -v /tmp/.X11-unix/:/tmp/.X11-unix
Unable to find image '' locally
r32.5.0: Pulling from nvidia/l4t-base
5000a6c32c5a: Downloading  10.46MB/24.57MB
8e855b69096a: Download complete
8db8dbbd4bb9: Download complete
833dc3235950: Downloading  526.2kB/172.4MB
f79d264135a3: Verifying Checksum
1c40f77bb35b: Waiting


I solved ,It is the jetpack version problem.
The image I ran was based on jetpack 4.4.1 ,4.4.1 and 4.5.1 are quite different
Thank you!

hello,i have a question,how can I mirror from a basic image, such as ubuntu:18.04 , install CUDA, tensorrt, pycuda step by step。Now the image is downloaded from the official website, which meets my needs, but it’s very big. There are many software I don’t need. So I want to customize the installation myself