Does JP4.6.1 sdcard oem setup boot break integrity of initrd installed nvme ssd OS?

It seems , having initrd flashed directly to nvme jetson [ JP4.6.1]
then inserting written with a sdcard image a microsdcard [JP 4.6]
then doing oem setup from the booted sdcard [ setting up user /password] then rebooting
then removing the microsdcard
results in Jetson NX not booting anymore from nvme as it was before before using the sdcard?
Could you confirm?
Which are the steps to restore booting from nvme?

Could you share the uart log under such case?

@WayneWWW will mini usb-b port of NX output the uart log in such case?

That is what dmesg shows on AGX in case of powering on NX connected by USB-A to usb-mini-B adapter to usb-A port of AGX

usb 1-1: new high-speed USB device number 17 using tegra-xusb
[  +0.148768] usb 1-1: New USB device found, idVendor=0955, idProduct=7e19, bcdDevice= 1.02
[  +0.000037] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  +0.000004] usb 1-1: Product: APX
[  +0.000005] usb 1-1: Manufacturer: NVIDIA Corp.

usb-B mini output is empty, if to read with

 sudo gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyGS0

No, I want to see the uart(bootloader) log. That usb port can only give out kernel side log.

I can wire pins of NX to AGX
it will require to determine which exacyly pin of NX to connect to which pin of AGX
then which command to run on AGX to render the output from NX

You can use the cable here.

BTW, I am just wondering, you have been here for years and you didn’t dump uart log even once?

Seems pins 8 & 10 of NX could be wired to pins 10 & 8 of AGX

Which command to run on AGX is still to determine

I am more curious why hasn’t usb-b mini uart dump support hasn’t been added for convinience of users

I am not sure why you want to use AGX as another host and sounds like you are doing UART to UART connection.

Please just use usb-ttl cable and use the usb port on the other side. Just UART → USB connection and focus on the real issue you want us to help check.

As for your question, uart log includes lots of bootloader components logs and not all of them are able to launch usb. Actually, the earliest bootloader component that launch tegra usb function is cboot. Also, we have other processor other than CPU that would also send log to uart. Which is also not supporting usb.

@WayneWWW ,
I do not have ‘usb-ttl’ cable.
If I will try to order it it will take a week
In my current situation I connected uart of nx to uart of agx. pins 8-10 to 10-8
Now seems it is required to determine which command to run on AGX to get uart from nx

I have noticed one more thing: flashing AGX to initrd nvme with sdkmanager
also formats eMMC without letting know it will get formatted.
is that how it is intended to be?

Why do we move the discussion to AGX now? Isn’t our issue on NX?

so lets try to execute on AGX

/sbin/getty -a ubuntu -L 115200 ttyTHS0 &

to see uart from NX
as in

or this should do perhaps?

sudo gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyTHS0

as you may see it is a compound issue : we are trying to read uart from nx at agx
output seems empty

to narrow down the issue
Q1: In order to read uart output at AGX that comes from NX UART
we need just one wire from pin8[ 40 pin header] on NX devkit wired to pin 10[40 pin header] of AGX devkit, right? - I also tried the uart tx header near sdcard slot, but it won’t work either
Q2: In order to read 40 pin header pin10 uart readings on AGX the command below should suffice?

sudo gtkterm -b 8 -t 1 -s 115200 -p /dev/ttyTHS0

Q3: if the output of the previous step is empty is it issue due to Q1 or Q2? both? Neither of the two?

if the UART-UART isn’t supported though it worked for a momentum in the past - I recollect posting about it with screenshot in the forum]
how to inspect the cause from NX booted from sdcard?
what oem-setup from sdcard at NX has changed that prevents initrd nvme ssd prior implementation to boot?

Please use usb-ttl cable. If you don’t have one, please get one.

This cable is helpful in every jetson platform.

I do not have usb-ttl. It is highly unlikely that I will get one in the nearest future
It wasn’t supplied with jetsons
I have AGX, nano, NX devkits and simple wires that can connect uart pins

If you cannot provide any log, then unfortunately I cannot help.

how would you suggest retrieving log from uart?
with uart-to-uart wiring

I don’t know. Didn’t try that before.

is it likely that one time booting from sdcard written with image
rewrites cboot in a way it affects nvme initrd boot?
However, I can boot the NX from sdcard
But nvme initrd boot seems gone