Download NVIDIA Driver R455 for Linux Kernel 5.9+

We advise customers updating to Linux Kernel 5.9+ to use the latest NVIDIA Linux GPU driver R455 that will be available for download from NVIDIA website and repositories, starting today . Linux Kernel 5.9+ contained changes that were incompatible with NVIDIA’s Linux GPU drivers released so far, as a result, these drivers were not supported on Kernel 5.9+. Hence, in order to have a fully functioning driver on Linux Kernel 5.9+, we require customers to update their NVIDIA Linux GPU driver to R455. NVIDIA is aware of the impact and inconvenience this will have on our customers, and we request your utmost support.

Are there any announcements about backporting Linux 5.9 support to the 450 series for those of us who require modesetting? We can’t upgrade since the 455 series has the bug that periodically crashes various apps with page allocation failures.