CUDA, Linux Kernel 5.5, and Davinci Resolve

The Davinci Resolve video editor requires CUDA to be installed on linux in order to function. For the past year I have had CUDA installed from the Nvidia Repository with my GTX 1060 and all has been well. The problem is the Nvidia driver in the CUDA respository is 440.33.01, which will not support Linux Kernel 5.5 and beyond. So I cannot install CUDA now because it requires the 440.33.01 driver, and if I use the 440.33.01 driver linux can’t boot into a GUI. The only solution seems to be to use an older linux Kernel, and that isn’t very exciting to me.

Does anyone know of any other solution? Is Nvidia going to update the CUDA repository to be compatible with a more modern video driver?