Unable to install CUDA 8.0 and drivers for Ubuntu 16.04; kernel package is not supported

Hello,

I am running Ubuntu 16.04 x86_64, 920M trying to install CUDA 8.0. I have been trying to install NVIDIA CUDA and the graphics driver to run Caffe. I have tried multiple approaches to install the driver but each time I get:

ERROR (dkms apport): kernel package linux-headers-4.4.0-46-generic is not supported

I have used the command line, .run file (separate driver and CUDA kit .run files as well as combined .run file) but the driver never get installed correctly.

I have tried the following approaches:

  1. NVIDIA-Linux-x86_64-367.57.run
  2. sudo apt-get install cuda-367
  3. cuda_8.0.44_linux.run (with the default driver)

What is the right way to go about installing CUDA 8.0 on 16.04? I have tried answers from these forums as well:
[1] https://devtalk.nvidia.com/default/topic/938988/cuda-setup-and-installation/-solved-cuda-8-0-on-ubuntu-16-04-gpu-not-available/1
[2] https://yangcha.github.io/GTX-1080/

I have also faced the login loop during one of my installation tries, I resolved that following these steps:

It would be great if someone could help me resolve this issue and suggest a correctly working way to install CUDA.

follow the instructions in the CUDA linux install guide carefully:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#axzz4TZuLDHjw

They assume a fresh install. If this is not a fresh install, then you should either reload the OS or carefully follow the instructions in that guide for cleaning out old installs. Also note that you appear to be mixing runfile install methods with package manager install methods. This is generally a bad idea and is mentioned in the install guide.