DPDK over OVS hardware - offloaded Bluefield SmartNIC

Hello

I am still working on OVS and DPDK on Bluefield SmartNIC.

(https://community.mellanox.com/s/question/0D51T00006zBdRNSA0/ovs-hw-offload-in-smartnic)

I tried running DPDK after offloading OVS on SmartNIC hardware.

In my knowledge, I thought I would be able to control packet forwarding by HW-offloaded OVS with the highest priority. However, when I ran DPDK, it ignored offloaded rules, and receive/transmit packet.

Does DPDK completely ignores OVS rules? Or is there any way to run DPDK over OVS?

Thanks.

Hi,

Once you added your ovs rules and the offloading is enabled .

ovs-vsctl set Open_vSwitch . other_config:hw-offload=true

(check also the hw-tc-offload via ethtool -k | grep hw-tc-offload)

You will be able to dump the flows that are offloaded

ovs-dpctl dump-flows type=offloaded

Let me know if it answers your question.

Marc

I’ve set hw-offload option of ovs, but it still didn’t work.

Actually, I could not find any rules by ovs-dpctl, while ovs-ofctl showed bridge rule which is currently forwarding packets between the network(p0) and host(pf0hpf).

Is there any special way to make a hw-offloaded rule?