Dpdk-testpmd fails with: common_mlx5: Failed to create SQ using DevX

[root@cu-testpmd build]# ./app/dpdk-testpmd -l $LCORES --main-lcore=$(echo $LCORES | sed -e ‘s/(.).*/\1/g’) -a $MLX_PCIEADDR,txq_inline_max=512 – --port-numa-config=0,0 --socket-num=0 --burst=64 --txd=256 --rxd=256 --mbcache=512 --rxq=32 --txq=32 --forward-mode=txonly -i --nb-cores=1 --txonly-multi-flow --mbuf-size=2176

EAL: Detected 24 lcore(s)

EAL: Detected 1 NUMA nodes

EAL: Multi-process socket /var/run/dpdk/rte/mp_socket

EAL: Selected IOVA mode ‘VA’

EAL: No free hugepages reported in hugepages-2048kB

EAL: No available hugepages reported in hugepages-2048kB

EAL: Probing VFIO support…

EAL: VFIO support initialized

EAL: Probe PCI driver: mlx5_pci (15b3:101d) device: 0000:b5:00.0 (socket 0)

common_mlx5: Failed to create SQ using DevX

mlx5_pci: Can’t create sq object.

mlx5_pci: FUNCIONS: mlx5_dev_spawn:1236

EAL: mem_free Error: Invalid memory

mlx5_pci: probe of PCI device 0000:b5:00.0 aborted after encountering an error: Operation not permitted

common_mlx5: Failed to load driver = mlx5_pci.

[root@cu-testpmd build]# mstvpd b5:00.0

ID: ConnectX-6 Dx EN adapter card, 100GbE, Dual-port QSFP56, with PPS In/Out, PCIe 4.0 x16, Crypto and Secure Boot

PN: MCX623106PC-CDAT

EC: A2

V2: MCX623106PC-CDAT

SN: MT2022X19516

V3: 8ae07ad3b8abea1180000c42a198c870

VA: MLX:MN=MLNX:CSKU=V2:UUID=V3:PCI=V0:MODL=CX623106P

V0: PCIeGen4 x16

root@cu-testpmd build]# mstflint -d b5:00.0 q

Image type: FS4

FW Version: 22.31.1014

FW Release Date: 30.6.2021

Product Version: 22.31.1014

Rom Info: type=UEFI version=14.24.13 cpu=AMD64,AARCH64

type=PXE version=3.6.403 cpu=AMD64

Description: UID GuidsNumber

Base GUID: 0c42a1030098c870 4

Base MAC: 0c42a198c870 4

Image VSD: N/A

Device VSD: N/A

PSID: MT_0000000500

Security Attributes: secure-fw

Hi,

Unfortunately, question has no info about what is the DPDK version running.

Be sure you are using lates 20.11.3 (LTS) and if the issue is still happens, test if it present in 21.05 and 21.08

If you were able to run testpmd before, what is different between now and then?

Hi, Thanks for the response. dpdk-testpmd works with 20.11.3 from dpdk-stable. Previous offending version was 20.11 and worked until firmware upgrade. One additional question on l2fwd-nv. The program fails with message with the message not being able to parse the device:

./l2fwdnv -l $LCORES --main-lcore=$(echo $LCORES | sed -e ‘s/(.).*/\1/g’) -a $MLX_PCIEADDR,txq_inline_max=0 #-- -m 1 -g0 -w 3 -P 0 -b 64 -B 1 -c 1 -d 9216

************ L2FWD-NV ************

EAL: Detected 24 lcore(s)

EAL: Detected 1 NUMA nodes

EAL: Detected static linkage of DPDK

EAL: failed to parse device “0000:b5:00.1”

EAL: Unable to parse device ‘0000:b5:00.1,txq_inline_max=0’

EAL: Error - exiting with code: 1

Cause: Invalid EAL arguments

Let me know to submit a new case if need be.

Glad to hear original issue solved.

Regarding second question, create a new post with adding extended command line in such way that instead of “echo XXX| sed YYY” and MLX_PCIEADDR there will be a real content.

Why there is an “#” on the command line?

Thanks will open a new case.