Driver install disappears after reboot (Geforce GTX 1050, Ubuntu 18.04, driver v. 430, kernel 5.3.2)

For a long time my nvidia drivers along with CUDA worked fine. One day everything decided to die and I am now trying to reinstall the drivers and CUDA.

I am running Ubuntu 18.04 on an ASUS laptop with a Geforce GTX 1050.

I have tried different linux kernels, but I get the same error for all of them.

The following works:

sudo apt purge nvidia*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-driver-430

After a reboot it is also seems to be working. I then try to install cuda by:

sudo dpkg -i cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb
sudo apt-key add /var/cuda-repo-10-0-local-10.0.130-410.48/
sudo apt update
sudo apt install cuda

Note that this has previously been working fine on my machine and other people with same setup. During the installation this error is produced:

ERROR (dkms apport): kernel package linux-headers-5.3.2-050302-generic is not supported
Error! Bad return status for module build on kernel: 5.3.2-050302-generic (x86_64)

Same error has happened with other kernel versions.

I have attached the bug report.

EDIT: I just experienced the exact same issue on another laptop. I can think of two changes that has happened on both machines:

  1. Both were recently moved to North America from Europe.
  2. Both have had the mesa-vulkan-drivers installed.
    nvidia-bug-report.log.gz (71.1 KB)

Please use a current 440 driver from the Ubuntu graphics ppa for the 5.3 kernel.