Driver refuses to accept working modeline (4K@120, DP->HDMI 2.1)

Thought I’d try here too… I have been stuck using 435 driver for a few months, because anything after that refuses to output 120Hz signal to my display. I’m using a 2080Ti with a Club3D CAC-1085 adapter (DP1.4->HDMI 2.1), which worked fine with the display.

The modeline for the display (LG CX) that worked with 435 was:
“3840x2160_120” 1186.81 3840 4016 4104 4400 2160 2168 2178 2250 +Vsync +Hsync
However now this just results in xrandr telling me “BadMatch (invalid parameter attributes)”.

I have tried calculating other modelines based on the EDID. These are:
1097.25 3840 3888 3920 4000 2160 2163 2168 2287 +hsync -vsync
1501.69 3840 4192 4624 5408 2160 2161 2164 2314 -HSync +Vsync

But all of these fail when trying to run xrandr --addmode after setting the new mode.

Any ideas on why? And also any hints for a better modeline/config?

This is what the 460 driver defaults to:
“3840x2160” 594.00 3840 4016 4104 4400 2160 2168 2178 2250 +hsync +vsync

As it’s nearly impossible to get a proper HDMI 2.1 card still, it would be great if this issue could at least be bypassed.

Thanks.

Here’s the display EDID if anyone is interested to run it throught edid-decode or something else:
00 ff ff ff ff ff ff 00 1e 6d c8 c0 01 01 01 01 01 1e 01 03 80 a0 5a 78 0a ee 91 a3 54 4c 99 26 0f 50 54 a1 08 00 31 40 45 40 61 40 71 40 81 80 d1 c0 01 01 01 01 08 e8 00 30 f2 70 5a 80 b0 58 8a 00 40 84 63 00 00 1e 66 21 50 b0 51 00 1b 30 40 70 36 00 40 84 63 00 00 1e 00 00 00 fd 00 18 78 1e ff 77 00 0a 20 20 20 20 20 20 00 00 00 fc 00 4c 47 20 54 56 20 53 53 43 52 0a 20 20 01 aa 02 03 61 f1 5e 61 60 76 75 66 65 db da 10 1f 04 13 05 14 03 02 12 20 21 22 15 01 5d 5e 5f 62 63 64 3f 40 2c 09 57 07 15 07 50 57 07 01 67 04 03 6e 03 0c 00 10 00 b8 3c 24 00 80 01 02 03 04 6a d8 5d c4 01 78 80 53 22 00 00 e2 00 cf e3 05 c0 00 e3 06 0d 01 e2 0f ff 68 1a 00 00 01 00 28 78 00 6f c2 00 a0 a0 a0 55 50 30 20 35 00 40 84 63 00 00 1e 00 00 00 00 00 00 00 00 00 00 00 00 bf

According to edid-decode, the edid is garbage.
Furthermore, if a DFP has a usable edid, any custom modelines are normally disabled and needs the “AllowNonEDIDModes” Modevalidation option set. So it’s rather odd this worked previously.
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hm. That’s strange. I can decode it just fine but now attached as bin.

“AllowNonEDIDModes” is set, just ran x with logverbose 6 and got some more info (I suppose this can be found in the bug report as well):

[ 2358.878] (WW) NVIDIA(GPU-0): The EDID for LG Electronics LG TV SSCR (DP-0) contradicts
[ 2358.878] (WW) NVIDIA(GPU-0): itself: mode “3840x2160” is specified in the EDID;
[ 2358.878] (WW) NVIDIA(GPU-0): however, the EDID’s valid HorizSync range (30.000-255.000
[ 2358.878] (WW) NVIDIA(GPU-0): kHz) would exclude this mode’s HorizSync (269.730 kHz);
[ 2358.878] (WW) NVIDIA(GPU-0): ignoring HorizSync check for mode “3840x2160”.
[ 2358.878] (WW) NVIDIA(GPU-0): Mode is rejected: DP Bandwidth check failed.
[ 2358.878] (WW) NVIDIA(GPU-0): GPU extended capability check failed.
[ 2358.878] (WW) NVIDIA(GPU-0): Mode “3840x2160_120” is invalid.
[ 2358.878] (WW) NVIDIA(GPU-0):

After trying with HorizSync at 27-270, I’m still stuck with DP Bandwidth check failed and GPU extended capability check failed.

I wonder if the check can be bypassed? The EDID would probably not provide completely invalid modes.

nvidia-bug-report.log.gz (711.9 KB) edid.bin (256 Bytes)

Try adding
NoDisplayPortBandwidthCheck
to the modevalidation option
https://download.nvidia.com/XFree86/Linux-x86_64/384.98/README/xconfigoptions.html
As a sidenote, the nvidia linux driver always had its issues with those 3DClub converters.

That was a productive hour.

Tried everything from UseEDIDFreqs to NoExtendedGpuCapabilitiesCheck and NoDisplayPortBandwidthCheck, but nothing. I can get the modes listed again, but trying to use them results vary from black screen, to x restoring the old mode to cpu locks and driver crashes.

Must keep looking / trying… but thanks for the hints.

The issues with the DP to HDMI 2.1 adapter don’t seem to be limited to Linux, though. The Windows drivers stopped listing 120Hz modes for some around the same time as the Linux driver was updated (reported by people on the Club3D forum).

I suppose if nothing else helps, I have to revert back to the old driver