Enabling boot loader redundancy on Custom board

Hi,

To enable boot loader redundancy, I followed “Tegra_Linux_Driver_Package_Boot_Loader_Update_Process.pdf” document.
This guide is working well on TK1 reference Board but fail to our custom board.
We are using CD575M and reference board using CD580M

Below is my flash configuration.
It works on reference board but not on our custom board.
It fail to jump boot loader and goes recovery mode on custom board.
I can’t see any error message why it fail to find boot-loader.
If I disable EB2, EB1, EBT filename and enable only EB3 filename,
it can boot but offline modifications doesn’t work.
From the symptom, looks like boot ROM fail to read BCT or fail to validation hash.

Any clue why this problem happen?
Is there any other constrain or do I need to enable special register?
What can be make this problem?
Please help.
Thanks in advance.

[device]
type=sdmmc
instance=3

[partition]
name=BCT
id=2
type=boot_config_table
allocation_policy=sequential
filesystem_type=basic
size=8388608
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=PPT
id=3
type=data
allocation_policy=sequential
filesystem_type=basic
size=2097152
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=ppt.img

[partition]
name=PT
id=4
type=partition_table
allocation_policy=sequential
filesystem_type=basic
size=2097152
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=GP1
id=5
type=GP1
allocation_policy=sequential
filesystem_type=basic
size=2097152
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=EB3
id=6
type=bootloader
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=u-boot.bin

[partition]
name=EB2
id=7
type=bootloader
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=u-boot.bin

[partition]
name=EB1
id=8
type=bootloader
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=u-boot.bin

[partition]
name=EBT
id=9
type=bootloader
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=u-boot.bin

[partition]
name=LNX
id=10
type=data
allocation_policy=sequential
filesystem_type=basic
size=16777216
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=SOS
id=11
type=data
allocation_policy=sequential
filesystem_type=basic
size=6291456
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
#filename=recovery.img

[partition]
name=NVC
id=12
type=data		#TEGRABOOT
allocation_policy=sequential
filesystem_type=basic
size=2097152
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
#filename=nvtboot.bin

[partition]
name=MPB
id=13
type=data		#MTSPREBOOT
allocation_policy=sequential
filesystem_type=basic
size=6291456
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
#filename=mts_preboot_si

[partition]
name=MBP
id=14
type=data		#MTSBOOTPACK
allocation_policy=sequential
filesystem_type=basic
size=6291456
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
#filename=mts_si

[partition]
name=APP
id=15
type=data
allocation_policy=sequential
filesystem_type=basic
size=15288238080
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=system.img

[partition]
name=DTB
id=16
type=data
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=tegra124-jetson_tk1-pm375-000-c00-00.dtb

[partition]
name=EFI
id=17
type=data
allocation_policy=sequential
filesystem_type=basic
size=67108864
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
#filename=efi.img

[partition]
name=USP
id=18
type=data
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=TP1
id=19
type=data
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=TP2
id=20
type=data
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=TP3
id=21
type=data
allocation_policy=sequential
filesystem_type=basic
size=4194304
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0

[partition]
name=WB0
id=22
type=data	#WB0BOOT
allocation_policy=sequential
filesystem_type=basic
size=2097152
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
#filename=nvtbootwb0.bin

[partition]
name=UDA
id=23
type=data
allocation_policy=sequential
filesystem_type=basic
size=2097152
file_system_attribute=0
partition_attribute=0
allocation_attribute=0x808
percent_reserved=0

[partition]
name=GPT
id=24
type=GPT
allocation_policy=sequential
filesystem_type=basic
size=0xFFFFFFFFFFFFFFFF
file_system_attribute=0
partition_attribute=0
allocation_attribute=8
percent_reserved=0
filename=gpt.img

Hi
We are investigating now. Will update here once have any information.

Hi Jack
Could you change your strap pin the same as jetson TK1.

Hi Shane,

Thank you very much.
Our configuration of RAM_CODE[3:0] was 0011 like schematic you posted.
We checked Evaluation board and found it’s configuration is 0010
We changed and it start to work.

Thank you very much for your support.

Hi Guys,

We are facing with very strange problem on bootloader. We created custom board based on TK1 CD575M - A1 with SDIN8DE4 - 16G Taiwan made one and SKYHYNIX CFR-PBA 4 rams. We did full SHMOO test successfully and created necessary files. Successfully flashed IMG files in to the system. However, system stops on very early stage of the booting.

It is very strange because when we flash android os on this exact same system it works. Last month, we made 10pcs of exact same sample boards which were working fine. When we flash L4T in to this system, it shows following error. Please help us to sort out this issue guys. Thanks!

Here I attached my log and i have no clue with this problem at all.

U-Boot SPL 2014.10-rc2-g3127911 (Jun 07 2016 - 21:00:01)                        
                                                                                
                                                                                
U-Boot 2014.10-rc2-g3127911 (Jun 07 2016 - 21:00:01)                            
                                                                                
TEGRA124                                                                        
Board: NVIDIA Jetson TK1                                                        
I2C:   ready                                                                    
DRAM:  2 GiB                                                                    
MMC:   Tegra SD/MMC: 0, Tegra SD/MMC: 1                                         
*** Warning - bad CRC, using default environment                                
                                                                                
tegra-pcie: PCI regions:                                                        
tegra-pcie:   I/O: 0x12000000-0x12010000                                        
tegra-pcie:   non-prefetchable memory: 0x13000000-0x20000000                    
tegra-pcie:   prefetchable memory: 0x20000000-0x40000000                        
tegra-pcie: 2x1, 1x1 configuration                                              
ERROR: tegra-pcie: failed to power on PHY: -110                                 
                                                   
at /dvs/git/dirty/git-master_linux/3rdparty/u-boot/drivers/pci/pci_tegra.c:740/)
ERROR: tegra-pcie: failed to enable controller                                  
at /dvs/git/dirty/git-master_linux/3rdparty/u-boot/drivers/pci/pci_tegra.c:1055)
In:    serial                                                                   
Out:   serial                                                                   
Err:   serial                                                                   
Net:   No ethernet found.                                                       
Hit any key to stop autoboot:  0                                                
MMC: no card present                                                            
switch to partitions #0, OK                                                     
mmc0(part 0) is current device                                                  
Scanning mmc 0...                                                               
GPT: last_usable_lba incorrect: 1D58FFF > 1D52000                               
get_partition_info_efi: *** ERROR: Invalid GPT ***                              
GPT: my_lba incorrect: 1D59FFF != 1D51FFF                                       
get_partition_info_efi: *** ERROR: Invalid Backup GPT ***                       
** Invalid partition 1 **                                                       
GPT: last_usable_lba incorrect: 1D58FFF > 1D52000                               
get_partition_info_efi: *** ERROR: Invalid GPT ***                              
GPT: my_lba incorrect: 1D59FFF != 1D51FFF                                       
get_partition_info_efi: *** ERROR: Invalid Backup GPT ***                       
** Invalid partition 1 **                                                       
GPT: last_usable_lba incorrect: 1D58FFF > 1D52000                               
get_partition_info_efi: *** ERROR: Invalid GPT ***                              
GPT: my_lba incorrect: 1D59FFF != 1D51FFF                                       
get_partition_info_efi: *** ERROR: Invalid Backup GPT ***                       
** Invalid partition 1 **                                                       
GPT: last_usable_lba incorrect: 1D58FFF > 1D52000                               
get_partition_info_efi: *** ERROR: Invalid GPT ***                              
GPT: my_lba incorrect: 1D59FFF != 1D51FFF                                       
get_partition_info_efi: *** ERROR: Invalid Backup GPT ***                       
** Invalid partition 1 **                                                       
GPT: last_usable_lba incorrect: 1D58FFF > 1D52000                               
get_partition_info_efi: *** ERROR: Invalid GPT ***                              
GPT: my_lba incorrect: 1D59FFF != 1D51FFF                                       
get_partition_info_efi: *** ERROR: Invalid Backup GPT ***                       
** Invalid partition 1 **                                                       
GPT: last_usable_lba incorrect: 1D58FFF > 1D52000                               
get_partition_info_efi: *** ERROR: Invalid GPT ***                              
GPT: my_lba incorrect: 1D59FFF != 1D51FFF                                       
get_partition_info_efi: *** ERROR: Invalid Backup GPT ***                       
** Invalid partition 1 **                                                       
(Re)start USB...                                                                
USB0:   USB EHCI 1.10                                                           
scanning bus 0 for devices... 1 USB Device(s) found                             
USB1:   USB EHCI 1.10                                                           
scanning bus 1 for devices... 1 USB Device(s) found                             
       scanning usb for storage devices... 0 Storage Device(s) found            
       scanning usb for ethernet devices... 0 Ethernet Device(s) found          
                                                                                
USB device 0: unknown device                                                    
No ethernet found.                                                              
missing environment variable: pxeuuid                                           
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/00000000                                          
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/0000000                                           
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/000000                                            
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/00000                                             
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/0000                                              
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/000                                               
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/00                                                
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/0                                                 
No ethernet found.                                                              
missing environment variable: bootfile                                          
Retrieving file: pxelinux.cfg/default-arm-tegra124                              
No ethernet found.                                                              
missing..