Error: Application returned non-zero code -1073741676

I run visual profiler on Windows 11 x64. I compile a cuda program and run it. It runs well. No problems. Returns zero at the end of main function.

Next I run visual profiler (I have tried v10.0 and v11.5 and there is the same problem).
I create new session, leaving all params by default, specifying only the *.exe file to profile. Leave checkbox “start execution with profiling enabled” set.
So then, after I create session, the execution and profiling starts and it all goes well. I can see the timeline and properties of all kernels I ran.

Then I click any of “Examine GPU Usage”, “Examine Individual Kernels” or any other option from “Guided Analysis” and “Kernel Perfomnance Limiter”, “Kernel Latency” or any other option from “Unguided Analysis”. And for any selected option I have the same error.

– unable to collect metric and event values.
– “The application being profiled returned a non-zero return code”

And the following message in console
– Error: Application returned non-zero code -1073741676

I cannot figure out what might be wrong. This error appeares with even the simplest cuda programs. With any program from cuda samples. The program itself runs well, but when I run nvvp, I have this error message for any selected analysis option


We could not reproduce this issue locally. We tested it on a machine having Windows 11 and Volta GV100 with CUDA Toolkit version 11.5 and Driver version 510.89. All the features of Visual Profiler including “Examine GPU Usage”, “Examine Individual Kernels” or any other option from “Guided Analysis” and “Unguided Analysis” work as expected. CUDA sample mergeSort was used for testing. What GPU you are running on?

Do you see the similar issue with the command line profiler nvprof? Options --events, --metrics or --analysis-metrics can be tried.

Another option is to do a clean installation of the CUDA toolkit after uninstalling & cleaning up of all the installed CUDA toolkits on the system.