visual profiler error codes

Hi,

i keep receiving an error while profiling my code :

Error: application being profiled returned a non-zero return code …

I am not sure what the problem is. The Code is healthy and memcheck returns o errors. Why is this happening? I have been able to profile the same code before i switchied into Cuda 5.5 rc …

best,
Thanasio

On most operating systems a non-zero process exit code indicates an error in the application. The Visual Profiler is warning that it detected a non-zero process exit code from the target application.

  1. Does the target application return a non-zero process exit code when run outside of the Visual Profiler? If yes, then fix the target application.

  2. Does the target application return a non-zero process exit code only when launched from the Visual Profiler? If yes, then debug what error is occurring in the application. These types of errors are often cause by a difference in the process launch environment including but not limited to:

  • Incorrect working directory
  • Incorrect command line arguments
  • Incorrect environment variables

These three settings can be specified in the Visual Profiler session settings.

hello guys,

Did you solved this problem? how can I solve this problem, HELP!
I also encounter this error:

==3481== NVPROF is profiling process 3481, command: ./a.out
Internal profiler error (8589934593:999)
==3481== Profiling application: ./a.out
==3481== Profiling result:
No kernels were profiled.
======== Error: Application returned non-zero code 1

nvprof version is 5.5; pgf90 version is 17.4;

Hi thanasio,

Did you solved this problem later? really hope to your reply.

try using CUDA 8, rather than CUDA 5.5

Thank you for your rely, I have already solved this problems.Actually I installed cuda 8 and cuda tookit 8, but may be a wrong environment setting is made. Thank you for your kind help

yuan-ubuntu:
How to solve the problem?
I have a problem same as you.
the error message is “The application being profiled returned a non-zero return code”
I already debugged my code.
but when I use the nvvp, that error occurs…

make sure you have a

return 0;

statement at the end of your main routine, or wherever your application is exiting.

Thank you for your reply.
It already fed into the main routine. (i.e., return 0 is fed into the main code)
So, you guess that problem is the application exiting part, right?

int main(int argc, char ** argv) {
	parameter_handler param(argc, argv);

	pr_algorithm alg;
	bool set_indicator = false;
	float gpu_cache_percentage = 90;

	engine e(alg, param, set_indicator, gpu_cache_percentage);
	e.run();

	return 0;
}

your application may be exiting somewhere else besides that return 0 statement.

Figuring out why your application returns a non-zero error code is really not a CUDA programming question.

Thank you I will check my code again!

I found a reason for the problem.
A part of my code needs ‘sudo mode’.
So when I execute the code root mode, it works.
but when I execute the code user mode, it doesn’t work.

Do you know the how to execute sudo mode at the nvvp?

Switch to a root user.

Run nvvp.

https://www.wikihow.com/Become-Root-in-Ubuntu

Thank you so much, Robert_Crovella!!!
I did it!

I resolved this issue.

The root cause is that I have no ‘writing permission’ to the working directory I used in nvvp.

The working directory in nvvp should be the path you ran *.exe without nvvp.