Error in Jetbot's object_following sample: 'tensorrt.tensorrt.Runtime' object has no attribute 'destroy'

I ran just the first two lines of the sample:

from jetbot import ObjectDetector
model = ObjectDetector('ssd_mobilenet_v2_coco.engine')

and netted this error:

[TensorRT] WARNING: Using an engine plan file across different models of devices is not recommended and is likely to affect performance or even cause errors.
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
File "/usr/local/lib/python3.6/dist-packages/jetbot-0.3.0-py3.6.egg/jetbot/tensorrt_model.py", line 136, in destroy
self.runtime.destroy()
AttributeError: 'tensorrt.tensorrt.Runtime' object has no attribute 'destroy'

What do you think is the cause of this error?

Hi,

Did you setup the software based on this page?
https://github.com/NVIDIA-AI-IOT/jetbot/wiki/software-setup

There is a customized image for JetBot.

Thanks.

Yes, I followed that procedure before I ran that code on my Jetson Nano

Hi,

Which TensorRT version do you use?
Suppose you should use the v5.0 from JetPack4.2.

Thanks.

Yes, I’m using those. It’s a fresh flash of the Nano with Jetpack4.2

Hi,

Do you use python3?
Thanks.

I have met the same problem. Do you solve it?