error in linux

make command gives below error for devicequery :

/usr/bin/ld: cannot find -lcutil
collect2: ld returned 1 exit status
make: *** […/…/bin/linux/release/deviceQuery] Error 1

if anyone can help me to sort out this error…
Thanx in advance…

ld (your linker) can’t find the cutil lib.

Make sure it’s installed.

Thanks for your reply.

But how can i check whether “cutil lib” is installed or not,please guide as i don’t have much knowledge of system…

From the same directory that you’ve tried to run that SDK example, issue:

find ../.. -name 'libcutil*'

Then, remember the output of this command (say “…/…/lib”), and then re-run the example:

LD_LIBRARY_PATH=../../lib ../../bin/linux/release/deviceQuery

I didn’t find libcutil* anywhere on the system ,when i tried with root login .

Where can i got the required library…

Are you sure that:

updatedb; locate libcutil

run as root gives no result? It is strange, as libcutil is part of the SDK, and when you try to compile examples, libcutil is built first, so you should probably not be able to get to the link phase of building deviceQuery example at all… In any case, you should be able to compile libcutil by going into the top-level directory of your SDK installation, and running

“make” there.

problem solved…

as i was running the make at incorrect path…

thanx for your help…