Error installing CUDA Toolkit 11.3 on Ubuntu 20.04 focal

I am trying to install CUDA Toolkit 11.3 on my Ubuntu 20.04 focal and there is a Makefile error when compiling nvidia-dkms-465. I tried to purge the installation and reinstall but the error doesn’t go away. I checked that my system defaults to the gcc/g++/cc versions used by kernel modules (which is gcc-9). I followed the instructions here to install the toolkit.

Here is my system info:

$ lsb_release -a
LSB Version:	core-11.1.0ubuntu2-noarch:security-11.1.0ubuntu2-noarch
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.3 LTS
Release:	20.04
Codename:	focal

Here are all the logs:

nvidia-dkms-465.0.crash (910.1 KB)

installation.log (42.4 KB)

Can someone please help me out? Thanks!

Don’t install the full “cuda” package (the driver is too old for the current kernel), instead install the lastest driver using Ubntu’s Software&Updates, then follow the mentioned instructions but instead of installing ‘cuda’ install just the toolkit:
sudo apt install cuda-toolkit-11-3

1 Like

Thank you @generix, downloading nvidia-driver-495 with cuda-toolkit-11-5 solved the problem for me!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.