Error: No PCIe DMA channels were identified while running run_test.sh on Nvidia Jetson Nano which is connected to XILINX Artix-7 A7 FPGA

Hi, I’m using Nvidia Jetson Nano(ARM64, Linux version 4.9.253-tegra) as a host to connect to a XILINX Artix-7 A7 FPGA via PCIE x4. I found the linux Xilinx XDMA driver(Xilinx_Answer_65444_Linux_Files, v0.45) on Internet. Tried to follow the usage on readme.txt, (1)Compile the module driver- success (2) Compile the provided example software in tests folder- success (3) load the driver - success (4) run_test.sh - failure

it fails executing run_test.sh by indicating “Error: No PCIe DMA channels were identified”(see ths snapshot as attached, the run_test.sh just do some read and write test via PCIE to Xilinx FPGA XDMA)
Does anyone know the root cause of it? (I’ve attached the driver packageXilinx_Answer_65444_Linux_Files.7z (492.6 KB)
)

P.S. It worked on Ubuntu of x86 PC (meaning can successfully pass the run_test.sh when XILINX Artix-7 A7 FPGA connected to x86 PC on Ubuntu)

That error looks like coming from the driver. Can you please share the output of ‘sudo lspci -vvvv’ before and after loading the driver?