ERROR:: ptx file problem. generate incorrect ptx file which is the same with the obj file

I 'm new for Optix,
my environment are optix3.9 and cuda7.5, how to make the compiler convert the .cu file to ptx file correctly?

my visual studio is 2013 . in fact ,i google it and make the compiler the generate ptx file .but ,the ptx file was wrong .i opened the ptx file and found content is the same with the obj file .

what’s wrong with my compiler ? and how to set compiler to generate ptx file correctly?? it’s hard for me …

Which version of Microsoft Visual Studio 2013 did you use?
If it’s MSVS 2013 “Professional” or MSVS 2013 “Community” you should be fine. “Express” editions are not supported by CUDA.

What is the machine bitness you’re generating PTX for?
It needs to be 64 bit. 32 bit is not supported anymore with OptiX.

Are you using the “Debug” target?
Make sure the CUDA to PTX compilation is not containing any debug information. OptiX doesn’t handle them.
That is, the nvcc command line must not contain -g or -G options.