Error running mnistCUDNN sample in ubuntu

Hi, I am trying to install the tensorflow gpu framework and I got some troubles with the cudnn. I run the mnistCUDNN sample to verify mu installation and I got the below output:

cudnnGetVersion() : 7605 , CUDNN_VERSION from cudnn.h : 7605 (7.6.5)
Host compiler version : GCC 7.5.0
There are 1 CUDA capable devices on your machine :
device 0 : sms 22  Capabilities 7.5, SmClock 1815.0 Mhz, MemSize (Mb) 5911, MemClock 4001.0 Mhz, Ecc=0, boardGroupID=0
Using device 0

Testing single precision
Loading image data/one_28x28.pgm
Performing forward propagation ...
Testing cudnnGetConvolutionForwardAlgorithm ...
Fastest algorithm is Algo 0
Testing cudnnFindConvolutionForwardAlgorithm ...
^^^^ CUDNN_STATUS_SUCCESS for Algo 0: 0.030720 time requiring 0 memory
^^^^ CUDNN_STATUS_SUCCESS for Algo 1: 0.069536 time requiring 3464 memory
^^^^ CUDNN_STATUS_SUCCESS for Algo 2: 0.071744 time requiring 57600 memory
^^^^ CUDNN_STATUS_SUCCESS for Algo 5: 0.103584 time requiring 203008 memory
^^^^ CUDNN_STATUS_SUCCESS for Algo 7: 0.118624 time requiring 2057744 memory
Cublas failure
Error code 0
gemv.h:77
Aborting...

Some more information:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 418.87.00    Driver Version: 418.87.00    CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1660    Off  | 00000000:01:00.0  On |                  N/A |
| 27%   41C    P8     9W / 120W |    211MiB /  5911MiB |      1%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0       989      G   /usr/lib/xorg/Xorg                            78MiB |
|    0      1438      G   cinnamon                                      31MiB |
|    0      8622      G   ...uest-channel-token=16736224539216711033    99MiB |
+-----------------------------------------------------------------------------+
CUDNN_VERSION from cudnn.h : 7605 (7.6.5)
Host compiler version : GCC 7.5.0
Tensorflow: 2.1.0-rc0;
CUDNN lib is in my LD_LIBRARY_PATH

What did I do wrong? How can I pass the mnistCUDNN test?

Hi,

Please verify and install the driver properly as per support matrix.
https://docs.nvidia.com/deeplearning/sdk/cudnn-archived/cudnn_765/cudnn-support-matrix/index.html
Use the method in the linux install guide. Perform all steps including verification, before attempting to do anything else
https://docs.nvidia.com/deeplearning/sdk/cudnn-archived/cudnn_765/cudnn-install/index.html#installlinux

Thanks