Error while flashing OS into xavier NX

Hello All,
I’m getting the below Error while flashing the Compiled os into Jetson Xavier NX

Making recovery ramdisk for recovery image…
Re-generating recovery ramdisk for recovery image…
/home/mr/ayyan/Linux_for_Tegra/bootloader/ramdisk_tmp /home/mr/ayyan/Linux_for_Tegra/bootloader /home/mr/ayyan/Linux_for_Tegra
30402 blocks
cp: cannot stat ‘/home/mr/ayyan/Linux_for_Tegra/rootfs/usr/bin/w’: No such file or directory
failed command: cp -fv /home/mr/ayyan/Linux_for_Tegra/rootfs/usr/bin/w /home/mr/ayyan/Linux_for_Tegra/bootloader/ramdisk_tmp//bin/w

But i have verified that the file W is available

@WayneWWW @ShaneCCC

Did you try the command manually?

yes i have tried the cp command manually

it is working if i do manually,

Yes i have solved the issue. in that script cp -f was there i changed to cp -fr after the change it started working

Hello @ShaneCCC

Now I’m gettiing this ERROR
Error: Return value 2
Command tegrarcm_v2 --download bct_bootrom br_bct_BR.bct --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt --download bct_mem mem_rcm_sigheader.bct.encrypt
Failed flashing t186ref.

please try to share full log and also the log from uart console.

Also, is this a new jetson xavier NX? Did you flash this module before?

i Have flashed with sdkmanager it was successfull it is working fine

Is the version you flashed by sdkmanager same as what you are flashing now?

The flash Log
CompileLog (36.1 KB)

hello @ShaneCCC

How can i get uart log while flashing th os


I guess your successful case with sdkmanager is not 32.5 BSP, right?

Yes Correct @WayneWWW

What version was that? This issue seems due to PCN update.

You can think it as new module does not work in old BSP.

It is Jetpack 5.10

that means L4T 32.5 not possible to install ?? @WayneWWW

try L4T 32.7.1 and it shall work.

yeah okay @WayneWWW but i have done my driver for 32.5