Error with AWS Nvidia driver detection on Debian 11 with nvidia Tesla k80, many methods tried

We’re running into a driver issue on AWS Debian 11 with the Tesla K80. Specifically a p2.8xlarge. I’ve attached the log file here. The installations are failing and
Here is what we’ve tried:
->Reinstalling the drivers.
->Different Debian versions (10 and 11)
->Downgrading kernel version from 6.1.xx to 5.10.xx
->Different nvidia drivers (v470, v440, v418, v390x legacy)
->Different methods of installation (wiki from debian, .run from nvidia)
->Assortment of grub configs for kernel
->Also blocklist additions/removals for nouveau updates
What are we missing here?
nvidia-bug-report.log.gz (34.2 KB)

There are no dkms logs included so I guess the kernel headers are missing. The correct driver would be 470, please install that and reinstall headers using
sudo apt install --reinstall linux-headers-$(uname -r)
afterwards, pleas epost the output of
dkms status
and create a new nvidia-bug-report.log after reboot.

Thanks for replying.

We just patched up the issue, there were some issues with conflicting sources and also it ended up working with kernel 5.10.x and not 6.1.x