ESDF incorrectly weighting obstacles

I am working on a project using nvblox in an indoor environment with the Realsense 435i on the jetson orin nano. My ESDF slice, does identify the ‘green’ areas close to walls and other obstacles but does not ever show ‘red’ in rviz for a true obstacle. As a result, nav2 will never route around these walls. Are there configurations to weight the obstacles more heavily?

Hi @kitsu.ELP

There are different ways to tune Isaac ROS NVBLOX, from the parameter list:

ROS Parameter Type Default Description
esdf_2d_min_height float 0.0 The minimum height, in meters, to consider obstacles part of the 2D ESDF slice.
esdf_2d_max_height float 1.0 The maximum height, in meters, to consider obstacles part of the 2D ESDF slice.

You can detect the obstacles on your drone route by tuning these parameters.

Raffaello