Ethernet port only 100M speed

We design a new carrier board on Xavier, And the ethernet port designed with reference to the demo board. but Now it is that only 100 megabit rate can be negotiated.
Can you give me some suggestion.


If you use ethtool to disable auto negotiate and set the speed to 1000, will it be able to set up?

I try to use
sudo ethtool -s eth0 autoneg off
sudo ethtool -s eth0 speed 1000

and the result seemed can use the 1000M

nv@nv-desktop:~$ ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: No
Advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: MII
Transceiver: internal
Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
Link detected: yes

What can I do for it?

Did you have any customization on AGX? Also, since disabling auto negotiation can make it work, could you check if the switch/hub side is causing the auto negotiation result to be 100?

This is a board made by ourselves. The schematic diagram of this part is copied from the dome board. I have tried the dome board (p2822_b03) on the switch side, and it can be directly negotiated to be 1000m. What do I suggest about positioning

this is part of the
tmp_schematic.pdf (323.1 KB)


So your ethernet phy is changed and different from the devkit?

Yes, I find we use the RTL8211 instead of 88e1512,How should I modify the driver?

Please contact with the vendor.

You can also refer to our device tree in Xavier NX. That one is also using rtl8211F.

OK, I will try to do it, Thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.