Fail to install cuda

Hi,
I am recently trying to install cuda toolkit. And the end goal is for “nvidia-smi” command to show the expected output, instead of showing “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

I have been following this linkhttps://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#ubuntu-installation link to install cuda. but even if cuda is installed, post-action from the link is done, the output of “nvidia-smi” is still the same, “NVIDIA-SMI has failed because …”

I found my situation is very familiar  to this [url]link[/url]https://devtalk.nvidia.com/default/topic/1058302/unable-to-install-nvidia-driver-on-ubuntu-18-04/  , but the solution you posted there does not work for me. Hence I am curious if there is anything else i can do to solve my  situation.

nvidia-bug-report.log.gz (97.6 KB)

I have uploaded my nvidia-bug-report.log.gz file. Hope it’s helpful.

So far, I have tried to install cuda-toolkit-10-1 and cuda-toolkit-10-0. Both do not work for me

You have secure boot enabled so the driver doesn’t load. Please disable secure boot in bios, then follow the steps from the thread you found.