Failed to install intel 3165NGW in Jetson TX2 dev kit with L4T r32.1

Hi All,
I performed following steps to install intel 3165NGW wifi on M.2 connector in Jetson TX2 dev kit but failed. I got seveval pcie “Response decoding error”. Please see attached log “r32-1.log”. The same steps can install this intel wifi chip successfully with L4t r28.3. Please see attached log “r28-3.log”. Is there any way to resolve this issue or anything I need to do in L4t r32.1 ?

  1. Set ODMDATA to 0x90000 in p2771-0000.conf.common.

  2. Modify device tree files.


@@ -60,7 +60,7 @@
 			gpios = <TEGRA_MAIN_GPIO(R, 3) 0>;
 			label = "pcie-lane2-mux";
-			status = "disabled";
+			status = "okay";
 		e3325_sdio_rst {
@@ -239,7 +239,7 @@
 				nvidia,lanes = "otg-2";
 				nvidia,function = "xusb";
 				nvidia,port-cap = <TEGRA_PADCTL_PORT_HOST_ONLY>;
-				status = "disabled";
+				status = "okay";
 			e3325-usb3-std-A-SS {
@@ -130,9 +130,8 @@
         xhci@3530000 {
 		phys = <&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(0)>,
-			<&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(1)>,
-			<&tegra_xusb_padctl TEGRA_PADCTL_PHY_USB3_P(0)>;
-		phy-names = "utmi-0", "utmi-1", "usb3-0";
+			<&tegra_xusb_padctl TEGRA_PADCTL_PHY_UTMI_P(1)>;
+		phy-names = "utmi-0", "utmi-1";
 	pinctrl@3520000 {

r28-3.log (88.3 KB)
r32-1.log (260 KB)

Are you sure you installed the firmware?

[   10.051413] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-7265D-26.ucode failed with error -2
[   10.051415] iwlwifi 0000:01:00.0: Falling back to user helper

Hi WayneWWW,
I am sure I have installed linux-firmware package. But why fails to load the firmware will cause the pcie “Response decoding error”?

Could you try to disable ASPM function and test again?

Hi WayneWWW,
It works. I can now connect to the Internet with intel 3165. Do you think that turning off aspm will cause any other side effect?

Hi, I’m working on a nano trying to get this card working. I disabled the aspm function by adding pcie_aspm=off after “quiet” to the /boot/extlinux/extlinux.conf file but that doesn’t seem to fix it. Bluetooth works but Wi-Fi doesn’t. Do I need to do anything else?