[?] Tegra TK1 Jetson compatible PCIe Wifi+BT?

[?] Tegra TK1 Jetson compatible PCIe Wifi+BT?

i been pulling my hair off to find proper driver for my wifi+BT pcie card (BCM43142)

is there other mini-pcie wifi+BT that is easier to get it working with Jetson?

I think several of us here at the forums have been pulling our hair out at this same thing with our various PCIe dual cards. I for one can’t even get a usb wifi dongle to work, even with “plug and play” drivers.

I compiled a module for my ATH9K card download the firmware and placed it in the /lib/firmware folder but it still does not work

rfkill list shows the interface still blocked and it can’t be unlocked!

Next i will try a new kernel and not just modules.

maybe we should consider a android port… i know BCM43142 works in android kitkat…

Anyone have any luck? Nvidia are you there?

There are two devices listed here under the Hardware Features section:
http://elinux.org/Jetson_TK1

One of intel:

The other link goes to an index page…

This is the exact PCIe I own and have correctly installed the drivers for. For some reason, I can not get the kernel to recognize it as an ethernet device to use for internet.

I have been trying to get the Intel 7260 card to work but so far I have not been successful. The device will come up using lspci but I don’t think I am able to load the driver. I would also love some help with this.

You will need to do the following:

Make sure build-essential is installed - do this with apt-get install build-essential

Do the following as root, or sudo

1: make sure you have the kernel sources extracted - I put an SD card in my tk1 and extracted them there from the sources that are provided on the system (Sorry I can’t remember the location but there’s a tarball on there, or on the L4T download)

2: Make a link to the sdcard extracted src dir to /usr/src/linux

3: zcat /proc/config.gz > /usr/src/linux/.config

4: cd /usr/src/linux

5: make oldconfig

6: make menuconfig
- Go through options and enabled drivers for Intel Wireless (iwlwifi)
- Save settings

7: Actually all this is mentioned here too - https://devtalk.nvidia.com/default/topic/751707/jetson-tk1-kernel-recompile-guide/

You need that Intel Firmware - Please let me know if the 7260 works as I’m currently in the same boat.

I just sent a message to NVIDIA support hoping for some sort of answer. This is a showstopper for me as well.

@sigkill

is there a version of Broadcom BCM wifi card as well?

I have done all of that, but still not work!

The command

rfkill unblock all

shows the wireless device is still locked by hardware (switch) ?

That’s correct - I did the same - also tried a broadcom pci card meant to get the model number it was from an HP Mini 311 and had several features locked.

Still no dice.

Tomorrow night I will try the 3160, 7260, 6230, and 6235 I have again. It seems like something is locked out here.

Still no response or update from Nvidia either.

We (NVIDIA) are aware that many devices currently need firmware drivers installed to “/lib/firmware” or building & flashing a custom L4T kernel. We will provide some instructions soon on how to build & flash a custom L4T kernel and will provide many common Wifi & webcam drivers on our Support page soon. But we want to know which drivers are the most desired.

I created a list of drivers at http://elinux.org/Jetson/Network_Adapters#List_of_desired_Wifi_chipset_drivers, if you don’t see your driver mentioned then add it to the list or email me (semami@nvidia.com).

Thanks for your patience!

Great idea! I added a request for Intel Wireless-N 2230 (mini-PCIE).

Still do not have the Jetson TK1, but next week should get to me.

I have a lot of experience in embedded systems, so I’ll try to significantly help!

Thank you for the update - I have been using the Intel 3160, 7260, 6235, and 6230. Additionally Broadcom devices, though the one I have is limited by HP.

I have installed firmware in /lib/firmware from Linux Wireless devices, but the cards still continue not to function. Wondering if maybe there is some specific code for none IA devices to communicate with these cards?

Well, looks like my next task is sidelined for now. 7260hmw. Already on the list.

bump? anything?

Checking back again here as well - still waiting for an update.

I’ve tried two separate mini PCIe cards with the same result:
Intel 7260 ac (iwlwifi)
Qualcom Atheros AR9462 (ath9k)

Both cards are enumerated by their respective drivers (compiled as modules and loaded via modprobe) but we need a way to either tell each driver to ignore rfkill, or implement some platform-specific rfkill interface. I also tried re-compiling the kernel with support for every rfkill-related option enabled.

$ sudo rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

I would like to note that I was able to get a rt2800usb dongle to work so somehow this is limited to PCIe devices. I need to be able to attach multiple antennas so USB is not an option.