Intel WiFi adaptor, Jetson

Hi,

I’m trying to install the driver for my Intel WiFi adaptor (7260HMW, mini PCIe). The driver I intend to use is iwlwifi. Unfortunately, in the backport’s stable directory there isn’t a perfect match for the kernel that the Jetson is running (3.10.24). Do you have any suggestions on how to adapt this driver to the TK1?

The following command lists correctly my network adapter:

$lspci -nnk | grep-iA2 net

Further, when I tried to compile backports-3.10.19, make couldn’t find the kernel’s header files, then I unsuccessfully tried to install the header files with:

sudo apt-get install linux-headers-$(uname -r)

It only worked with: “linux-headers-generic”, but these header files appear to be insufficient to iwlwifi.

I took a look in apt cache:

apt-cache search linux-headers

Indeed, there isn’t a something that corresponds to my install attempt.

Can someone lead me in the proper direction to solve this?

Use the kernel source offered in the Jetson Support Page (https://developer.nvidia.com/linux-tegra-rel-19)

[Easier Route]
Or use the precompiled Grinch Kernel pinned on the forum (https://devtalk.nvidia.com/default/topic/766303/embedded-systems/-customkernel-the-grinch-19-3-2-for-jetson-tk1/)

Good Luck :)

I am using the Grinch Kernel and continue to have problems with my Intel Corporation Wireless 7260 HMW. The connection is very intermittent. I have tried 2 different cards and 2 different TK1s. I am seeing other posts that it works so, I am wondering am I missing something.

Linux tegra-ubuntu 3.10.24-grinch-19.3.3 #1 SMP PREEMPT Sat Aug 16 22:49:01 UTC 2014 armv7l armv7l armv7l GNU/Linux

01:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)
Subsystem: Intel Corporation Dual Band Wireless-AC 7260
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 643
Region 0: Memory at 32200000 (64-bit, non-prefetchable)
Capabilities: [c8] Power Management version 3
Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Address: 00000000ab648000 Data: 0003
Capabilities: [40] Express (v2) Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 unlimited
ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr+ NoSnoop+ FLReset-
MaxPayload 128 bytes, MaxReadReq 128 bytes
DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <4us, L1 <32us
ClockPM+ Surprise- LLActRep- BwNot-
LnkCtl: ASPM L1 Enabled; RCB 64 bytes Disabled- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
DevCap2: Completion Timeout: Range B, TimeoutDis+, LTR+, OBFF Via WAKE#
DevCtl2: Completion Timeout: 16ms to 55ms, TimeoutDis-, LTR-, OBFF Disabled
LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
Compliance De-emphasis: -6dB
LnkSta2: Current De-emphasis Level: -3.5dB, EqualizationComplete-, EqualizationPhase1-
EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
Capabilities: [100 v1] Advanced Error Reporting
UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
CESta: RxErr+ BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
CEMsk: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
AERCap: First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-
Capabilities: [140 v1] Device Serial Number a0-a8-cd-ff-ff-3b-0a-92
Capabilities: [14c v1] Latency Tolerance Reporting
Max snoop latency: 0ns
Max no snoop latency: 0ns
Capabilities: [154 v1] Vendor Specific Information: ID=cafe Rev=1 Len=014 <?>
Kernel driver in use: iwlwifi

derrick313: Can you describe the symptoms? Lost the connection?

I found this: https://communities.intel.com/thread/47502

Sounds like popular problem with “n” standard and/or power saving.

Try add:

options iwlwifi 11n_disable=1 power_level=5

into /etc/modprobe.d/iwlwifi.conf

Santyago,
Thanks for the reply. I read the link that you posted concerning the possible power management problems with the card. I modified /etc/modprobe.d/iwlwifi.conf as you recommended as well as turning power management off with iwconfig wlan0 power off . The output of that command is “wlan0 Current mode:off”

The symptoms of my 7260 wireless are:

  1. Can only see 2 wireless networks from the tegra however, from my laptop I can see 19.
  2. Was able to connect to the 2 available networks only three times in three days.
  3. Once connected the signal seems to degrade after 3-5 minutes until it drops.
  4. After several unsuccessful attempts to connect to the wireless networks, the available networks via the Ubuntu desktop notification list disappears even though iwlist shows them.

I can provide output from dmesg if you find it helpful.

Again, thanks for the assistance.

I have also been experiencing issues with the Intel 7260 mPCIe and have tried the above solutions. Unfortunately the problem persists where it cannot connect to the wireless access point. There are rare instances where it will connect, only to have it disconnect a minute or so later. The signal strength reports 32/70, which isn’t very good but it should at least be capable of keeping a persistent connection. My laptop sees the same access point at near full strength. Could it be a firmware issue with the chip? Perhaps the ucode?

So I followed what Ramsey said in this in regards to getting the wifi on the 7260 to work https://devtalk.nvidia.com/default/topic/766303/embedded-systems/-customkernel-the-grinch-19-3-3-for-jetson-tk1/2/

and I end up getting the same problem as derrick313. When I made the edits into /etc/modprobe.d/iwlwifi.conf then doing iwconfig wlan0 power off and reboot, I can no longer see any wifi signals. I tried to go back to what Ramsey said in the other thread but when I tried to perform

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi

I get
ERROR …/libkmod/libkmod-config.c:686 kmod_config_parse: /etc/modprobe.d/iwlwifi.conf line 1:ignoring bad line starting with ‘VimCrypt-01!/…H’
modprobe: FATAL: Module iwlwifi is in use

Do you have antennas connected to your card? I could not see any wifi APs before I connected the antennas.

“Do you have antennas connected to your card? I could not see any wifi APs before I connected the antennas.”

I do not have antennas attached to either the laptop or the Tegra. Also, I have a Atheros AR9287 and it works great. Would like to get the 7260 working though.

Can you tell me what kind of bit rates you are seeing with the Atheros? I purchased the Atheros AR5BHB92 and cannot get anything above 6 MB/s. I have tried all the tricks on the web (see here http://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/) but I still can’t get a “good” connection. It is stable, compared to the Intel. I am wondering if I have to buy another wi-fi card? In the end, I will end up spending more on wireless cards than the actual dev board!

 Hi,

I have not attempted to do any optimize the 9287 howerver, iwlist provides this.

root@tegra-ubuntu:/home/ubuntu# iwlist wlan2 bitrate
wlan2 unknown bit-rate information.
Current Bit Rate=78 Mb/s

Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

I tested the 7260 with the suggested external antennas and while I do see additional wireless networks, the problem persists with card dropping connection.

Perhaps the problem is in differences in setup? I think I used the 3.10 firmware from http://wireless.kernel.org/en/users/Drivers/iwlwifi

Also, my router is cheap, a wireless N router. Perhaps you have an AC router and 7260 AC isn’t as stable? Have you tried connecting to any of the other visible wifi APs to see if they drop too?

Got the Intel 7260AC running out of the box with a fresh grinch 19.3.3 flash. Listening to Pandora through wifi, with Bluetooth headphones paired with the Bluetooth on the same card. Nice and fast, and solid as a rock.

Hello,
I’m having an issue with WiFi adaptor (7260HMW, mini PCIe). I can list all the wifi signal, but it just don’t connect. I execute sudo nmcli dev wifi con “SSID” password “mypassword” and I always get Error: Connection activation failed: (7) Secrets were required, but not provided.

The kernel I’m using

Linux tegra-ubuntu 3.10.40-ga7da876 #1 SMP PREEMPT Tue Jun 7 21:05:06 PDT 2016 armv7l armv7l armv7l GNU/Linux

Can any body help?

Thanks.