My Jetson TX1 is not able to connect to WiFi

Some small number of developer kits have a manufacturing problem that can impact WiFi.

Please go to https://developer.nvidia.com/embedded/support to download and run the wifi-config-check tool to find out whether you need to request a replacement developer kit via the RMA Process. Use the wifi-config-check tool to determine for sure, but signs of the affected behavior include:

  • clicking on the desktop Network Manager, shows WiFi “device not ready”.
  • dmesg kernel log includes repeating “mmc1: Data CRC error” followed by register dump. For the full text see: https://devtalk.nvidia.com/default/topic/897947/embedded-systems/wireless-problem-on-tx1/post/4737452/#4737452
  • system may be laggy from the repeated loggings noted above. Until your replacement arrives, temporarily disable WiFi to remove the lag:
    $ sudo mv /lib/firmware/brcm /lib/firmware/brcm_
    $ sudo reboot
    
  • scanning for WiFi networks will result in failure:
    $ sudo iw dev wlan0 scan
      command failed: Network is down (-100)
    

Thanks to those in the community for reporting earlier on their condition and S/N’s. We reached out to these individuals previously to get their process started. For others receiving factory units, please run the wifi-config-check tool to deem if your unit needs replaced. At this time we are doing advance replacement with shipments including return postage for the affected unit.

Mine came in the other day. Wireless is flawless now. Excellent support and quick turnaround on this issue. Now if you guys would just give us a cuda lib we can run on our chrooted 64 bit file systems all would be golden. I used the instructions here to set mine up https://wiki.debian.org/Debootstrap. It rocks in full 64 bit mode. An ARM64 cuda lib would be such a nice Christmas present :)

Griz

Hi Griz, the 64-bit filesystem is on our roadmap for L4T, but it won’t be in time for Christmas, sorry :)

Thank you!

Advance replacement would be nice. I hope this is still the case, because I have one.

Also, your script writers might want to note that not everyone keeps the “ubuntu” username, Hard coding that assumption into the script seems a bit… well… insert your word of choice :)

Joe

Out of the box my wifi was working fine. But wasn’t sure if there could be a problem deeper that I wasn’t aware of. So I tried downloading the wifi config tool from the Tx1 and everytime I did it with firefox (the version that comes on the board) it crashed the browser. Had to download from another computer and get it across my network. I guess I could have done it with a thumb drive as well seeing I have a USB hub connected. Anyway then I couldn’t get it to run no matter what I did until I set permissions on the file. So…

sudo chmod u+x ~/wifi-config.check.sh
sudo ./wifi-config-check.sh
The i2c-tools package is required
Download i2c-tools via apt-get [y/n]: (type Y for yes and hit enter. The following below is automated)
Running Apt-get update
Running apt-get install i2c tools

Checking MAC address configuration
Configuration error found. Correcting…
Please do not interrupt, or system data corruption can occur
Fixing naming of Wlan interface
Error corrected. The correct Mac address will be effective after reboot
Checking wifi settings next

=================================
Your developer kit is functioning correctly.

Please chec file: /home/ubuntu/wifi-config-check-log for more details
ubuntu@tegra ubuntu:~$

Then reboot/restart

You should still be plugged into ethernet so check ethernet connection: it should still be good. Unplug ethernet, activate your wifi network from the upper right hand corner drop down of the desktop. Login into your wifi network and test wifi connectivity. After all that you’re ready to rock.

So I tried downloading the wifi config tool from the Tx1 and everytime I did it with firefox (the version that comes on the board) it crashed the browser.

Not the most convenient workaround, but most of the time I have luck copying/pasting a download link and grabbing it with the “wget” command if the browser is acting up.

I am experiencing the wi-fi problem on TX1 S/N: 0320716034412

  • “Device Not Ready” and “mmc1:Data CRC error”

A couple of other notes:

  1. My wired ethernet connection would not work either until I ran: sudo mv /lib/firmware/brcm /lib/firmware/brcm_ and rebooted.

  2. My Ethernet wire connection was working OK until I ran steps 1 thru 7 of the TX1 install instruction for OpenPTrack: https://github.com/OpenPTrack/open_ptrack/wiki/Jetson-TX1-Installation This could be due to the MaxPerformance tweaks just manifesting the wifi issue.

  3. My TX was shipped July 27, 2016

Please advise on next steps.

Thanks

Jon Morris

Hi Jon, can you run the WiFi test tool: http://developer.download.nvidia.com/embedded/jetson/TX1/tools/wifi_config_check/wifi-config-check.sh

If it says you have the issue, please request RMA following the procedure from here: https://developer.nvidia.com/embedded/support In the event of RMA, they should send you a replacement unit in advance.

If you think the issue you’re experiencing may be related to item #2 from your post, you can try re-flashing your Jetson with the latest JetPack.

Wifi Test Tool verified a board Manufacturing problem. RMA in progress.

Unreal! I just got the replacement TX1 I requested by RMA and it has the same problem!

From the wifi-config-check-log:

This generated file provides details if the Jetson-TX1 is configured properly for Wireless connections or not

Serial Number of Module is 0322016080106
Serial Number for Base board is 0322116018045

A manufacturing problem has been detected. This may impact performance and stability of your developer kit. Please go to https://developer.nvidia.com/embedded/support to request a replacement. We are sorry for the inconvenience.

This is not good. Is it really just a “few” units affected?

Jon

Hello,

After flashing my Jetson TX1 board with Jetpack 2.3.1, I am unable to detect or connect to Wifi or use the device as a wireless access point: https://devtalk.nvidia.com/default/topic/910608/jetson-tx1/setting-up-wifi-access-point-on-tx1/. Flashing the board with Jetpack 2.3.1 was the first thing I did so I am unsure if there was functionality beforehand. I am able to access the internet via ethernet, but I am hoping to have this board host its own access point for use in my projects.

After a fresh re-flashing of Jetpack 2.3.1: https://developer.nvidia.com/embedded/jetpack, here is some output information:

ubuntu@tegra-ubuntu:~/Downloads$ sudo ./wifi-config-check.sh

Checking MAC address configuration
MAC address configuration is correct.
Checking WiFi settings next

=========================================
Your developer kit is functioning correctly.

Please check file: /home/ubuntu/wifi-config-check-log for more details

This returns nothing and no wireless signals are detected in network manager…
ubuntu@tegra-ubuntu:~/Downloads$ sudo iw dev wlan0 scan
ubuntu@tegra-ubuntu:~/Downloads$

ubuntu@tegra-ubuntu:~$ sudo ifconfig
[sudo] password for ubuntu:
enx00044b581aed Link encap:Ethernet HWaddr 00:04:4b:58:1a:ed
inet addr:172.16.2.142 Bcast:172.16.255.255 Mask:255.255.0.0
inet6 addr: fe80::204:4bff:fe58:1aed/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:708215 errors:0 dropped:0 overruns:0 frame:0
TX packets:35460 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:135889093 (135.8 MB) TX bytes:4106989 (4.1 MB)

enx503f56013424 Link encap:Ethernet HWaddr 50:3f:56:01:34:24
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:3739 errors:0 dropped:0 overruns:0 frame:0
TX packets:3739 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:380940 (380.9 KB) TX bytes:380940 (380.9 KB)

wlan0 Link encap:Ethernet HWaddr 00:04:4b:58:1a:eb
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

sudo rfkill unblock all - appears to enable bluetooth (icon can now be seen in the top-right menu tray) but has no affect on wifi

I had a live chat session earlier this morning and was asked to post my Wifi issue. Any help would be much appreciated.

Thank you,
Don

You may be interested in this thread:
https://devtalk.nvidia.com/default/topic/910608/?comment=4976505

@linuxdev, thank you for the quick reply!

That link appears to reference the same thread as my first link. It certainly looks like gold!

I suspect my lack of success with the WAP setup may not be too unrelated to not being able to attain basic Wifi functionality either.

Interesting, I thought I had a different link, but it is just the same as you already have. Sorry, my notes are apparently are missing a specific reply I was looking at.

Hello,

I currently have a similar problem to dbourque3. I can access the internet over an ethernet cable, but I need it to work with WiFi. The board is flashed with JetPack L4T 3.0 (OS-version 24.2.1). Here are some outputs:

ubuntu@tegra-ubuntu ~/boardconfig % sudo ./wifi-config-check.sh                                 :(

Checking MAC address configuration
MAC address configuration is correct.
Checking WiFi settings next

=========================================
Your developer kit is functioning correctly.
=========================================
Please check file: /home/ubuntu/wifi-config-check-log for more details
=========================================

But when running a scan, the board can’t find any WiFi:

ubuntu@tegra-ubuntu ~ % sudo iw dev wlan0 scan
ubuntu@tegra-ubuntu ~ %
ubuntu@tegra-ubuntu ~ % sudo ifconfig
eth0      Link encap:Ethernet  HWaddr 00:04:4b:5a:cd:e7  
          inet addr:192.168.188.27  Bcast:192.168.188.255  Mask:255.255.255.0
          inet6 addr: fe80::204:4bff:fe5a:cde7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2503 errors:0 dropped:0 overruns:0 frame:0
          TX packets:644 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:565220 (565.2 KB)  TX bytes:108849 (108.8 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:248 errors:0 dropped:0 overruns:0 frame:0
          TX packets:248 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:18833 (18.8 KB)  TX bytes:18833 (18.8 KB)

wlan0     Link encap:Ethernet  HWaddr 00:04:4b:5a:cd:e5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:6359 (6.3 KB)

I also checked the blocked interfaces:

ubuntu@tegra-ubuntu ~ % rfkill list all            
0: bluedroid_pm.42: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: brcmfmac-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Any help would be appreciated.
Thank you
Nil

Nil_,

Does “sudo iwlist wlan0 scan” work?

No, it has a similar result as “sudo iw dev wlan0 scan”:

ubuntu@tegra-ubuntu ~ % sudo iwlist wlan0 scan
wlan0     No scan results

ubuntu@tegra-ubuntu ~ %

Nil_,

Could you provide the dmesg after run sudo iw dev wlan0 scan?

After “sudo iw dev wlan0 scan” “dmesg” shows:

EDIT:
The output had too many linse to show here.

https://pastebin.com/3A9c1NgZ
dmesg.txt (71.2 KB)

Seems the link is broken?