how to enable wifi on TX1?

I got this TX1 board from former employee. It’s running fine with Ubuntu 16.04. I found one strange thing that I couldn’t configure WIFI.

nvidia@tegra-ubuntu:~/Downloads$ sudo ./wifi-config-check.sh

Checking MAC address configuration
MAC address configuration is correct.
Checking WiFi settings next

=========================================
Test inconclusive (WiFi settings unknown). Please make sure WiFi is enabled under network settings, reboot the system and re-run this test. If you encounter this error again, visit the product support page at https://developer.nvidia.com/embedded/support

Does anyone know how to enable WIFI?

cheers,

Steve

Hi scheng,

Do you flash it with Jetpack3.1 BSP? If you are not sure, could you try it first?

Does wlan0 interface show?

Yes, I flashed it two days ago. I don’t see wlan0 interface at all. Is there any hardware button/jumper or software flag to enable it?
nvidia@tegra-ubuntu:~$ ifconfig
enx00044b635324 Link encap:Ethernet HWaddr 00:04:4b:63:53:24
inet addr:10.10.50.192 Bcast:10.10.50.255 Mask:255.255.255.0
inet6 addr: fe80::b191:3da3:2400:ed44/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:69218 errors:0 dropped:0 overruns:0 frame:0
TX packets:60317 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:18023366 (18.0 MB) TX bytes:267088205 (267.0 MB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:11804 errors:0 dropped:0 overruns:0 frame:0
TX packets:11804 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:738114 (738.1 KB) TX bytes:738114 (738.1 KB)

nvidia@tegra-ubuntu:~$

Could you paste the kernel log as an attachment?

I am curious if this command works (I’m testing if sudo works…if prompted for password it probably works):

sudo ls

If that works, see if all is “ok” in:

sha1sum -c /etc/nv_tegra_release

I’m just thinking to make sure the NVIDIA-specific drivers are in place with proper permissions (WiFi requires sudo in places).

You may also post the output of :

rfkill list wifi
iwconfig
service network-manager status

Your ethernet adapter is named ‘enx00044b635324’, are you running standard L4T ?
On Jetson dev board it should be eth0… Are you using a different board or ethernet card ?

[EDIT: you may check this for similar symptoms: https://devtalk.nvidia.com/default/topic/1021660/jetson-tx1/is-there-any-other-method-in-l4t-r28-1-to-update-dtb-file-for-tx1-besides-flashing-the-dtb-partitio-/post/5223364/#5223364. Are you running a custom board, a modified device tree?]

for comment #5,

  1. yes, sudo works for sure. I got most stuff like opencv/cudnn/yolo/slam works.

nvidia@tegra-ubuntu:~ sha1sum -c /etc/nv_tegra_release /usr/lib/xorg/modules/extensions/libglx.so: OK /usr/lib/xorg/modules/drivers/nvidia_drv.so: OK /usr/lib/aarch64-linux-gnu/tegra/libtegrav4l2.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmmlite_utils.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvparser.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvtx_helper.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvfnetstoredefog.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvos.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvcameratools.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvdc.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmedia.so: OK /usr/lib/aarch64-linux-gnu/tegra/libglx.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvimp.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvcamlog.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvll.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvtvmr.so: OK /usr/lib/aarch64-linux-gnu/tegra/libargus.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvidia-egl-wayland.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvtestresults.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmm_contentpipe.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvcam_imageencoder.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmm_parser.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvcolorutil.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnveglstream_camconsumer.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvfnet.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvrm.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvddk_2d_v2.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvexif.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmmlite_video.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmm_utils.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvddk_vic.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvfnetstorehdfx.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvodm_imager.so: OK /usr/lib/aarch64-linux-gnu/tegra/libargus_socketclient.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvcamerautils.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvrm_graphics.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvomxilclient.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvjpeg.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvtnr.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvavp.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmmlite.so: OK /usr/lib/aarch64-linux-gnu/tegra/libargus_socketserver.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvrm_gpu.so: OK /usr/lib/aarch64-linux-gnu/tegra/libscf.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvapputil.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmmlite_image.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvosd.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvomx.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvwinsys.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnvmm.so: OK /usr/lib/aarch64-linux-gnu/tegra/libnveglstreamproducer.so: OK /usr/lib/aarch64-linux-gnu/libv4l/plugins/libv4l2_nvvidconv.so: OK /usr/lib/aarch64-linux-gnu/libv4l/plugins/libv4l2_nvvideocodec.so: OK nvidia@tegra-ubuntu:~

for comment #6,

nvidia@tegra-ubuntu:~ rfkill list wifi nvidia@tegra-ubuntu:~ sudo rfkill list wifi
nvidia@tegra-ubuntu:~ nvidia@tegra-ubuntu:~
nvidia@tegra-ubuntu:~$ iwconfig
enx00044b635324 no wireless extensions.

sit0 no wireless extensions.

lo no wireless extensions.

dummy0 no wireless extensions.

ip6tnl0 no wireless extensions.

tunl0 no wireless extensions.

nvidia@tegra-ubuntu:~$ service network-manager status
● NetworkManager.service - Network Manager
Loaded: loaded (/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled
Active: active (running) since Wed 2017-11-29 18:04:11 UTC; 23h ago
Main PID: 413 (NetworkManager)
CGroup: /system.slice/NetworkManager.service
├─ 413 /usr/sbin/NetworkManager --no-daemon
├─1291 /sbin/dhclient -d -q -sf /usr/lib/NetworkManager/nm-dhcp-helper -pf /var/run
└─1329 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfa

for comment #3,

nvidia@tegra-ubuntu:/var/log$ grep -i wifi kern.log
Nov 29 17:36:45 tegra-ubuntu NetworkManager[524]: [1511977005.2497] Read config: /etc/NetworkManager/NetworkManager.conf (etc: default-wifi-powersave-on.conf)
Nov 29 17:36:45 tegra-ubuntu NetworkManager[524]: [1511977005.4513] manager: WiFi enabled by radio killswitch; enabled by state file
Nov 29 17:36:45 tegra-ubuntu NetworkManager[524]: [1511977005.4678] Loaded device plugin: NMWifiFactory (/usr/lib/aarch64-linux-gnu/NetworkManager/libnm-device-plugin-wifi.so)
Nov 29 17:36:55 tegra-ubuntu NetworkManager[524]: [1511977015.6509] WiFi hardware radio set enabled
Nov 29 18:04:11 tegra-ubuntu NetworkManager[413]: [1511978651.2623] Read config: /etc/NetworkManager/NetworkManager.conf (etc: default-wifi-powersave-on.conf)
Nov 29 18:04:11 tegra-ubuntu NetworkManager[413]: [1511978651.5905] manager: WiFi enabled by radio killswitch; enabled by state file
Nov 29 18:04:11 tegra-ubuntu NetworkManager[413]: [1511978651.6195] Loaded device plugin: NMWifiFactory (/usr/lib/aarch64-linux-gnu/NetworkManager/libnm-device-plugin-wifi.so)
Nov 29 18:04:21 tegra-ubuntu NetworkManager[413]: [1511978661.0925] WiFi hardware radio set enabled
nvidia@tegra-ubuntu:/var/log$

You may get more info from:

cat /var/log/syslog |egrep -i "wifi|80211|wlan|bcm|dhd|Dongle Host"

Syslog has many details, but may have traces from previous runs. You may also generate the kernel log since last boot with

dmesg > kmesg.log

and attach file kmesg.log (you can only attach a file to previously sent post).

Furthermore, it may help to give your L4T version and tell if it is a standard or custom board, and if it is running a modified device tree/kernel/drivers/firmware.

head -n 1 /etc/nv_tegra_release
uname -a
ls -al /etc/modprobe.d/      #here you would check for bcmdhd.conf and no blacklisting of it
ls -al /lib/firmware/brcm/   
ls -al /lib/modules/<your_kernel_version>/kernel/drivers/net/wireless/bcmdhd/bcmdhd.ko
ls -al /dev/rfkill
cat /etc/network/interfaces
ls /etc/network/interfaces.d/
cat /etc/dhcp/dhclient.conf | grep -v "#"

=====
nvidia@tegra-ubuntu:~ cat /var/log/syslog |egrep -i "wifi|80211|wlan|bcm|dhd|Dongle Host" nvidia@tegra-ubuntu:~

dmesg log, enclosed,

nvidia@tegra-ubuntu:~$ head -n 1 /etc/nv_tegra_release

R28 (release), REVISION: 1.0, GCID: 9379712, BOARD: t210ref, EABI: aarch64, DATE: Thu Jul 20 07:45:59 UTC 2017

nvidia@tegra-ubuntu:~ uname -a Linux tegra-ubuntu 4.4.38-tegra #1 SMP PREEMPT Thu Jul 20 00:41:06 PDT 2017 aarch64 aarch64 aarch64 GNU/Linux nvidia@tegra-ubuntu:~ ls -al /etc/modprobe.d/
total 68
drwxrwxr-x 2 root root 4096 Nov 17 18:22 .
drwxr-xr-x 147 root root 12288 Nov 30 06:35 …
-rw-r–r-- 1 root root 2507 Jul 31 2015 alsa-base.conf
-rw-rw-r-- 1 root root 84 Nov 9 21:49 bcmdhd.conf
-rw-r–r-- 1 root root 325 Mar 13 2016 blacklist-ath_pci.conf
-rw-r–r-- 1 root root 1603 Mar 13 2016 blacklist.conf
-rw-r–r-- 1 root root 210 Mar 13 2016 blacklist-firewire.conf
-rw-r–r-- 1 root root 697 Mar 13 2016 blacklist-framebuffer.conf
-rw-r–r-- 1 root root 156 Jul 31 2015 blacklist-modem.conf
lrwxrwxrwx 1 root root 41 May 3 2016 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
-rw-r–r-- 1 root root 583 Mar 13 2016 blacklist-rare-network.conf
-rw-r–r-- 1 root root 1077 Mar 13 2016 blacklist-watchdog.conf
-rw-r–r-- 1 root root 390 Apr 12 2016 fbdev-blacklist.conf
-rw-r–r-- 1 root root 347 Mar 13 2016 iwlwifi.conf
-rw-r–r-- 1 root root 576 Nov 17 18:47 kvaser.conf
-rw-r–r-- 1 root root 104 Mar 13 2016 mlx4.conf
nvidia@tegra-ubuntu:~ ls -la /lib/firmware/brcm/ total 612 drwxr-xr-x 2 root root 4096 Nov 9 21:49 . drwxr-xr-x 6 root root 4096 Nov 9 21:49 .. -rw-rw-r-- 1 root root 613063 Nov 9 21:49 fw_bcmdhd.bin -rwxrwxr-x 1 root root 3157 Nov 9 21:49 nvram.txt nvidia@tegra-ubuntu:~ ls -al /lib/modules/4.4.38-tegra/kernel/drivers/
char/ usb/

=======================

looks like I don’t have bcmdhd.ko at all…

dmesg.log (71.6 KB)

Sorry, using syslog was not a good idea…Seems syslog has just been rotated and you got a fresh syslog file. Using the same egrep command on dmesg output would have been more relevant.

Anyway, looking at your demsg.log, it seems it doesn’t activates DHD. On my TX1 R28.1, I get these lines missing in your case:

xhci-tegra 70090000.xusb: cannot find firmware....retry after 1 second
 random: nonblocking pool is initialized
[b] dhd_module_init in
 found wifi platform device bcmdhd_wlan
 Power-up adapter 'DHD generic adapter'
 wifi_platform_set_power = 1
 wifi_platform_bus_enumerate device present 1
 wifi_platform_bus_enumerate device present 0
 F1 signature read @0x18000000=0x17214354
 F1 signature OK, socitype:0x1 chip:0x4354 rev:0x1 pkg:0x2
 DHD: dongle ram size is set to 786432(orig 786432) at 0x180000
 wifi_platform_prealloc: failed to alloc static mem section 7
 wifi_platform_get_mac_addr
 CFG80211-ERROR) wl_setup_wiphy : Registering Vendor80211
 wl_create_event_handler(): thread:wl_event_handler:240 started
 CFG80211-ERROR) wl_event_handler : tsk Enter, tsk = 0xffffffc0779e1a70
 dhd_attach(): thread:dhd_watchdog_thread:243 started
 dhd_attach(): thread:dhd_dpc:244 started
 dhd_attach(): thread:dhd_rxf:249 started
 dhd_deferred_work_init: work queue initialized 
 Dongle Host Driver, version 1.201.82 (r)
               Compiled in drivers/net/wireless/bcmdhd on Jul 20 2017 at 00:39:01
 tegra_sysfs_register
 Register interface [wlan0]  MAC: 00:04:4b:xx:xx:xx

 dhd_prot_ioctl : bus is down. we have nothing to do
 sdhci-tegra sdhci-tegra.1: Tuning already done, restoring the best tap value : 81
 wifi_platform_set_power = 0[/b]
 xhci-tegra 70090000.xusb: Firmware timestamp: 2016-11-24 02:31:08 UTC, Version: 50.18 release
 xhci-tegra 70090000.xusb: xHCI Host Controller
 xhci-tegra 70090000.xusb: new USB bus registered, assigned bus number 1
 xhci-tegra 70090000.xusb: hcc params 0x0184f525 hci version 0x100 quirks 0x00010810

The directories I sent were from a TX2 R28.1, sorry for TX1 it seems it should be:

/lib/modules/4.4.38-tegra/kernel/drivers/net/wireless/bcmdhd/bcmdhd.ko

Would you suggest how to fix it? thanks!

Hi Steve,

I was mainly helping to make the diagnosis, not sure I am a good therapist for this.
I have to say that I’m not using wifi on my TX2. Maybe there is enough information for someone else to figure it out.

For fixing this, I would consider that even fixing wifi may leave some other things broken, as I have no idea what your collegue has done with it, so the easiest way would be to download fresh JetPack and reflash. Updating packages after the new install, the whole process would take about an hour from now to get a full capabilities system running. If not, you may consider RMA if a hardware failure persists.

Of course, this depends on what work has been done on the Jetson, if it can easily be saved and reinstalled later…

It looks like a hardware issue here since reinstall also not work and dmesg shows DHD is gone.
I would suggest a RMA process here…