Wireless problem on Tx1

Just tried to putty into the Tx1. Doesn’t work. No login. Everything looks to be set up properly on the tx1 side. Dhcp working and all that. Works before installing the Jetpack.


Figured it out. Worked fine from another tk1 and with ssh -v localhost so determined it was something to do with keys. Sure enough if you use puttygen to generate ALL 3 KEY types it will work just fine.


Hi Griz,

I’m having somewhat the same issue. I just got the TX1 yesterday and updated the ubuntu via JetPack. the wireless shows “device not ready”… any idea how to fix this?

ubuntu@tegra-ubuntu:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            r8152
  State:             connected
  Default:           yes
  HW Address:        00:04:4B:57:FC:EC

    Carrier Detect:  yes
    Speed:           1000 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Prefix:          24 (


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            bcmsdh_sdmmc
  State:             unavailable
  Default:           no
  HW Address:        00:90:4C:11:22:33


  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 


ive already installed:

sudo apt-get install linux-firmware

and still the wifi is not working… any ideas?

I think this is being actively worked on.

Thank you for posting — we are investigating the issue. Can you run sudo nvidia-bug-report-tegra.sh on your Jetson and send us the file from /home/ubuntu/nvidia-bug-report-tegra.log? It contains additional logging that is captured.

Having the same issue. Am not able to use the wifi at all. Trying to piggy-back via my macbook, but its also not working… off to a good start :-/

Thanks Marco for confirming. The team is currently working to investigate and resolve the issue.

Is anyone able to report if their wireless is working as expected, and if so, does it work out-of-the-box and/or after flashing JetPack 2.0?

Well I was mistaken when I tried to connect with a tablet that just had wifi it wouldn’t. Can’t even ping it. Also audio on bluetooth isn’t working either. Can’t get my bluetooth headset to work properly. Audio is working but mic isn’t. Worked on tk1 no problems. Where should I send the file? Should I just post it here?


Never mind saw the addy when I ran program. Its in the mail.


dgmiller I ran that command on my system and it shows connected. Did you go into nm-connection-editor and set up the wifi link? I see mine on the router but can’t ping it from any other machine on my network.


Do you have your Jetson TX1 connected over ethernet, in addition to WiFi? Unclear if your WiFi is actually working or not.
Maybe you can post the output of nm-tool so we can compare to dgmiller’s.
Or the output of iw dev wlan0 scan would be good too, with others it seems to break when engaging the WiFi (as opposed to device enumeration).

Hi Dusty,

here is the output from that command on my TX1 (experiencing the same issues as griz)
nvidia-bug-report-tegra.log (6.21 MB)

Thanks for your log. We are working to resolve this issue and are trying to characterize more units from the field.
note: if you’re experiencing the behavior, please let us know the serial number of your unit.

For all who are facing WiFi issues, please share your serial number(S/N) written on a sticker on your board.

Thanks much. Mohit.

Regarding wifi “device not ready” issue, my module SN is 0324415032460.

Mine is already installed in the bot. Is there any way to get serial number without removing it? I think its 0324515042017 that is on the box it came in. The TK1 was connected via ethernet and wifi. I could move the monitor mouse and keyboard to that unit and unplug the ethernet and see if it works but I doubt it will. Can’t ping the wifi address of the Tx1. It shows up in the router. Looks like the same problem with putty I had when I switched to win 10 but that is easily solved by running puttygen and generating the keys. Tried that too with no luck. I’ll try with the TK1 and report back.



"Connects to 802.11ac Wi-Fi and Bluetooth enabled devices "
“Antennas to connect to Wi-Fi enabled devices (2)”

Can I translate this as that the TX1 Dev kit has now built in wifi?

wifi issue: module SN: 0324415032409

Yes WiFi is built in on the Jetson TX1 module