Wifi Install - Intel N 7620

Can someone walk me through installing the driver for the Intel N-7620 pci mini wifi/bluetooth card on the Jetson board? Intel has has this listed for a while now and I’ve heard its really good. Bought it before I checked to see if it even works on the Jetson.

Pictures with words would help. I"m very new to ubuntu/linux and programming in general…

What version of LT4 are you using? If you’ve upgraded to L4T 21.2 it’s pretty simple, otherwise there are a couple of alternatives.

Ubuntu 14.04.1 LTS


Now what?

I have the iwlwifi…ucode file on my desktop. Shouldn’t this just be as simple as:

sudo…command something…
%%% running

Might i suggest simply installing the grinch 21.2.1 kernel? As far as i know all the drivers and things are included in it. I simply added my 7260 and it worked, no setup was required.

‘ged4f697’ indicates that you have LT4 21.2. Just for future reference, since all versions that the Jetson currently support are Ubuntu 14.04, people distinguish the version by the Linux for Tegra (LT4) distribution revision.

The Grinch is a very good alternative (and probably the easiest path) for installing the 7260 and getting it to work.

However, just for completeness:

LT4 21.2 comes with the Intel drivers for wireless ( iwlwifi, iwldvm, and iwlmvm) already on board. However, it does not include the firmware needed by the 7260 card itself. The easiest way to install the firmware:

$  sudo apt-get install linux-firmware

Alternatively, if you already have the correct firmware code file on hand, you can copy it to the firmware directory:

$ sudo cp -v iwlwifi-7260-7.ucode /lib/firmware

With the firmware installed, there is another trick involved. In order to get the wireless to work, you must enable GPIO 191, which is used by the 7260:

echo 191 > /sys/class/gpio/export;
echo out > /sys/class/gpio/gpio191/direction;
echo 1 > /sys/class/gpio/gpio191/value;

The default is for the kernel to boot and always set this to OFF, so you must enable it on every boot. You do this by editing the file:

$ sudo gedit /etc/rc.local

and adding the above ‘echo’ lines before the last line in the file, which should be ‘exit 0’ . Make sure to save the file.

Note: In the Grinch kernel, the above procedure for GPIO 191 is not needed because it sets GPIO 191 by default.

After editing rc.local, reboot the Jetson. You should be able to see nearby wireless networks in the Network Manager menu. The Network Manager is the up/down arrow icon towards the upper right hand corner of the top toolbar. You should be able to connect to an open wireless network at this point.

Personally, I was not able to connect to a WPA/WPA2 protected network just by using the Network Manager menu and selecting a network because of some kind of bug.

However, you can manually configure a connection in that instance and it should work fine. You do this by the ‘Edit Connections…’ menu entry, and adding an entry.

You’ll need the SSID of the network you want to join.

You can get the SSID of nearby networks that the card can see (I’m sure there are prettier ways, but this one is valid)

$ sudo iwlist wlan0 scan

You’ll see the fields ‘Address’ and ‘ESSID’. Address is called BSSID when you ‘Edit Connections’ in the Network Manager, ESSID is called SSID in the Network Manager. Save your entry. Put in the password for the network in the ‘Wi-Fi Security’ tab. Make sure to save your new settings. You should be good to go at that point.

Jump on the wireless network, disable the ‘Wired Connection’ and take it for a spin.

Note: If you compile your own modules from kernel source for iwlwifi, iwldvm, and iwlmvm the Network Manager WPA connection dialog appears to work correctly.

All in all, it’s probably simplest to use the Grinch 21.2 kernel. This answer is here for those who only need to get the 7260 to work, and want the minimal impact on the stock configuration.

You can read more about a previous Intel 7260 install on LT4 21.1 install here, hopefully for a little context:

Thank you. Its timing out quite a bit. I thought I read somewhere what the fix was for that, but not I can’t find it…

Actually, its connecting and disconnecting quite a bit, this is a nightmare…
It can’t hold a connection. i was able to bring up google and search for nvidia and that was it, now it just can’t get it done.

Oh great, now the screen is locked up.

nVidia hopes to generate a market with this thing? seriously? ??? ;)

What type of antenna are you using?

antenna? Please tell me I don’t need to buy that to plug into the Intel 7260 chip in either the 1 or 2 hole just to pick up a signal…

I can tell if this is serious or not.

But yes, you need an antenna unless your jetson is <5 ft from your router/access point.

Also, is that a 3d printed abs/pla base/case? Looks like the model from nvidia’s website. neat.

I have no idea who the manufacturer is. I thought they were just all the same metal pigtail that connects to a plastic antenna…?

If you look very closely at the top of the mPCIe wireless NIC next to the mounting screws you’ll see two connectors. Those connectors are actually very tiny coaxial cable connectors. I’m not sure of requirements on this wireless NIC, but there are a couple of different short coaxial cables available for this type of connector…one type of which a capacitive coupling plate is available for something like a smart phone’s frame, or another type available for a tiny whip-style antenna. I have no idea what the recommendations are for this NIC’s antenna, but all radio devices do require some form of antenna.

Yes, the 3D printed case came from the website. Its somewhat disappointing because the 3D printer wasn’t extremely accurate as I’m used to other printers quality.

Finally got a chance to get back on this little side project. Had the internet wifi thing all worked out, 100%. I go away from it for 2 weeks and turn it back on. No wifi.
To say I’m stunned is an understatement. I spent hours getting it to work and now what? I have two antenna’s and it searches for the signal, finds the network and won’t connect.

My raspberry pi with a much MUCH much less powerful wifi card picks up the signal just fine and its sitting right next to the Jetson…

Can I not leave the thing sitting alone for 2 weeks and it resets? I guess I unplugged it at one point in that time but that shouldn’t matter should it?