Jetson TK1 - Wifi adapter

Hi,

Is it possible to use an usb wireless adapter with Jetson TK1 to connect to the internet?

Thank you

USB WLAN dongles should work independently of the platform used, so those should work just fine with Jetson.

i just got usb wifi dongle and when i plugged it in it doesn’t show up as wireless setting. does it not have wifi drivers? it’s panda usb wifi adapter. it says it works on ubuntu w/o any installation. i only see ethernet connection only (cable). any other ideas?

also, will it be possible to use usb to ethernet adapter to connect jetson board from my home desktop computer? will it connect to ionternet that way? it’s really useless w/o internet, not sure why they didn’t include wifi module on this board

i also noticed that it ships with firefox, i thought i read somewhere that chrome is the browser.

also i can’t run flash with firefox, i dont think they have one for 32 bit arm chips…

I would guess that the kernel doesn’t include drivers for all possible USB wifi dongles, so you should check if the kernel has the support enabled for it.

To connect with ethernet through your computer, you need to configure your computer to act as a DHCP server and a router.

If you want a wifi module, I think you can buy one and connect it to the mini-pcie slot. It also needs a driver enabled in the kernel though.

Would you mind to show how to check if the kernel has the support enabled for a USB wifi dongle?

Also, how can one configure a computer (Linux or Windows) to act as a DHCP server and a router?

Unfortunately there are many different USB wifi dongles with different drivers. If you know the driver name, you can check if it’s compiled in the kernel with:

zgrep CONFIG_USB /proc/config.gz

You need to replace CONFIG_USB with the actual driver option.

For setting up your own routing DHCP server, you may start with these:

https://help.ubuntu.com/community/isc-dhcp-server
https://help.ubuntu.com/community/Router

Although the Router page seems quite overkill and you may google for something more simpler.

Often many WIFI and ADSL boxes can also act as a routing DHCP server.

Hi,

I have a similar issue with wireless and Bluetooth connectivity on my Jetson after I reflashed it using the latest JetPack. I used a USB WiFi dongle to connect to the internet prior to the re-flash and it worked perfectly.

However, now the bluetooth settings are locked and I cannot unlock them using the traditional remedies listed out on Ubuntu support forums. Which in turn, I suspect, is the reason I cannot use my WiFi dongle.
Also, I just connected the WiFi Dongle to my PC for the first time and it works fine without the need to download any additional drivers.

Please advice if this might be due to a missing bluetooth driver, and in that case, what is the remedy.

Thanks.

On your PC, freshly booted with no WiFi dongle ever connected, run “lsmod” to see what modules are used. Then connect the dongle and use it for a connection. Run lsmod again, while WiFi is still connected, and see which modules are added for support (look for module changes). After this it should be easier to narrow down what drivers are involved and what configuration files might be related. The same before/after list of modules under Jetson would also be useful in comparison to the before/after modules of the PC.

Hi Linuxdev,

I ran lsmod in the following conditions:

  1. Internet connected via the Laptop’s inbuilt Intel Wireless adapter
  2. Internet connected via the USB WiFi dongle
  3. Disconnected Internet

I then ran a diff on the three files.

The results are:

  1. no difference in the lsmod outputs when connected using the USB Wifi Dongle and no connectivity.
  2. diff between lsmod outputs for Internet connectivity using the Interl Wireless adapter and USB Wifi Dongle is as under:

[i][b]3,4c3,4
< ctr 13049 0
< ccm 17773 0

ctr 13049 1
ccm 17773 1
34c34
< aesni_intel 152552 0


aesni_intel 152552 2 [/b][/i]

Also on my PC, there is an option to Enable WiFi or not in a drop down on the toolbar. And an option to turn Bluetooth on or off.
While on the Jetson, the bluetooth settings are locked, and the WiFi option in the connectivity drop down is absent.

Thanks.

I had hoped to see a module loaded to find out what driver was being used on the PC/laptop, but it seems the laptop’s internal hardware uses the same chipset as the dongle…which means drivers are already loaded and a diff of modules doesn’t reveal anything new.

What’s the exact USB WiFi model?

Hi the USB Wifi is [b]Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter[/b]

I noticed it is listed on http://elinux.org/Jetson/Network_Adapters#Wifi_adapters_tested_on_Jetson_TK1

as working.

The link shows as no bluetooth driver. Does the adapter work if you exclude bluetooth? Was bluetooth working on a prior Jetson release (if so which)?

FYI, looking at the default kernel config for L4T R21.4, “CONFIG_R9712U” is not set, so this module could be compiled to add the r8712u driver (listed as the driver for RTL8192SU) for the kernel shipped in R21.4.

Grinch kernel appears to have this already built. Were you previously using Grinch?

I received the board from someone recently and I am not sure if they used Grinch.
I will try and load the new Grinch Kernel onto it and try connecting using the USB WiFi adapter and will get back to you with results.

The Grinch Kernel did the trick for the wireless adapter.
However, the Bluetooth settings are still locked.
Can you provide any inputs on that?

I’ve never set up bluetooth, but what it comes down to is that this is a separate device of a composite hardware device (multiple independent functions on a single physical device). That web link you provided earlier indicated the bluetooth portion was not supported. The reason might be that no driver for this existed at the time, or that the driver simply wasn’t built by default…research would be required for the specific chipset or model of bluetooth and compared with various kernel versions for support (many of the drivers on Grinch were backports of later drivers which did not exist at the time of the L4T kernel). Knowing which driver (if any) support this bluetooth is key to fully answering your question.

I have the same issue. Did anyone solve it? Can you tell us what you did?