How can I install enable wifi on TK1 I bought both Intel 7260 Adapter and Edimax EW-7811

But dont know how to enable wifi onboard, is, my L4T is R21.2. I found a tutorial but ony for L4T R21.1.
Does anyone can help?
Thank you very much!

What’s the tutorial you found? Why doesn’t it apply to 21.2?

Now I reflashed to R19.3. Still can not work. where can I find the tutorial? itis not plugin and work immediately??

You’ve mentioned two different products on two different releases. What have you tried in order to get wifi working?

It is not plugin and work immediately under all versions.

There are two options under R19.3:

  1. Install the Grinch kernel (recommended). Follow the instructions here:
    https://devtalk.nvidia.com/default/topic/766303/embedded-systems/-customkernel-the-grinch-19-3-8-for-jetson-tk1/

  2. Build your own kernel module(s), install the module(s) and download the firmware for the device. Also, GPIO 191 must be enabled. Probably not worth the effort unless your project requires R19.3.

Options under R21.1 -

  1. Install the Grinch kernel. Follow the instructions here:
    https://devtalk.nvidia.com/default/topic/795734/embedded-systems/-customkernel-the-grinch-21-2-1-for-jetson-tk1/

  2. Build your own kernel module(s), install the module(s) and download the firmware for the device. Also, GPIO 191 must be enabled. For an overview see here:
    http://jetsonhacks.com/2014/11/15/build-modules-drivers-nvidia-jetson-tk1-lt4-21-1/

  3. For version R21.1, instructions on how to install pre-built modules are here:
    http://jetsonhacks.com/2014/11/12/install-compiled-intel-7260-driver-jetson-lt4-21-1/

Options under R21.2 and R21.3

Releases for R21.2 and R21.3 have the modules for the Intel built in.

  1. For the Intel 7260, modules come preinstalled. However, the actual firmware for the device needs to be downloaded and installed. To do this, excute on a Terminal:
$ sudo apt-get install linux-firmware

Which installs the firmware for the actual device itself. At this point, after a reboot, the 7260 should work. R21.2 had an issue which may require that you enter the WPA information manually, the only workaround that I found was to recompile and install the module myself. I have not tried to install the 7260 on 21.3.

I do not remember if GPIO 191 is enabled on 21.2 or not. If it is not, then the 7260 will not work, you must enable it. If not, you enable it by executing at startup:

echo 191 > /sys/class/gpio/export;
echo out > /sys/class/gpio/gpio191/direction;
echo 1 > /sys/class/gpio/gpio191/value;
modprobe -r iwlwifi;
modprobe iwlwifi;

by placing the above code in /etc/rc.local

I have not used the Edimax on 21.X

Good luck!