Failed to load swrast driver

The general topic is that these two errors appear quite often when I open programs through ssh to jetson nano.

MESA-LOADER: failed to open swrast (search paths /usr/lib/aarch64-linux-gnu/dri:$${ORIGIN}/dri:/usr/lib/dri)

libGL error: failed to load driver: swrast

to be specific in a use case:
I tried opening gazebo simulator through ssh , when I opened it with a monitor through HDMI it worked fine . Now it crashes with the same mentioned errors.

Note: The same error appeared when I was tinkering around x server and xrdp , most things done through ssh / xfce desktop / vnc showed the same errors often ( sorry for not being specific on each of those , But I am mentioning them only to enforce that this can’t be posted on gazebo forums as I think it is in the hardware scope)

Note: I tried gazebo headless mode , running gzserver only , but with same errors , and again I think that it is in the nano’s scope because the same error appears quite often

I know that the post seems to be with little info but I am waiting for anyone to request the suitable logs / settings from me as I didn’t know what exactly to post rather than the core errors

Thank’s in advance and apologies for the under informed post


If you are offloading the GPU function to another computer with ssh and X forwarding, then it is the other computer which needs matching OpenGL/CUDA/GPU capabilities. The Jetson no longer performs that function. Virtual desktops may be the topic you are really interested in.