Failed to pxe boot win10 if set start type of mlx4_bus and ibbus to 0(boot start)

We have a diskless(pxe) boot system, according to our experience, in order to boot with mellanox connect2 nic, we should always set mlx4_bus and ibbus service to boot start, it worked well for windows 7. Recently, we moved to win10, but if we do the same, win10 does’t boot, we debugged some processes of mlx4_bus and ibbus, only found that if we set boot start type to 0 for mlx4_bus and ibbus, there always lack of a \device\000000XX device to be created compared to a normal system, we don’t know why windows 7 is ok but windows 10 failed for the same nic to boot. Could anyone help me to solve this?

We’re using WINOF 5.5 version and still the same problem.

Have checked and found that the WinOF v4.80.5000 (from 2014) is the latest driver (mlx4_bus) that supported Mellanox connectX-2 adapter along with Windows 7 Client (64 bit only) & Windows 8.1 Client (64 bit only). Windows 10 is of course not supported, so that probably explains why it worked fine for you in Win7 but failed in in Win10

More information on that can be found in “WinOF Download Center” → Archive Versions

It’s been 10 months, are you fixed this issue?