Failed to start gdm3 after installing NVIDIA 515 driver on Ubuntu 20.04

I have a freshly installed machine with Ubuntu 20.04.

After installing the NVIDIA 515 driver using the ubuntu builtin installer, the machine failed to boot into the linux desktop. I saw a black screen.

Ctrl+Alt+F3 could start the console mode. Then I checked the Kernel drivers are loaded using NVIDIA-smi

The issue seems to be with gdm3, not with kernel loading.

Wasn’t able to find a working solution on the internet.

nvidia-bug-report.log.gz (1.4 MB)

Please try creating /etc/X11/xorg.conf

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddGPU" "false"

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:65:0:0"
    Option         "ProbeAllGpus" "False"

I suspect the A100 get added as virtual display.

Thank you very much! This solution worked! I can now boot into the desktop.

The only issue is, the resolution is very low, only 1024x768. Somehow it doesn’t detect the available resolutions.

Not sure if you could give me some advice. Thank you so much!

the xorg log seems to be strange, it tried to set those resolutions but failed.

Also not sure if I should see nouveau driver in the log? I checked nvidia-smi, it says no processes were using GPUs, I wonder if I was using the nvidia driver or nouveau.

Xorg.0.log (30.4 KB)

Here are the updated logs and my current config
xorg.conf (2.8 KB)
nvidia-bug-report.log.gz (241.5 KB)

You seem to have gotten the wrong driver after update, the open kernel modules.
Please switch to the no “-open” driver version in Software&Updates.

Thank you very much. I indeed installed the “open” kernel nv driver, because I thought Nvidia recently opened their kernel driver.

I just installed the non-open version of the 520 driver through software & updates. But it was the same.

X11 log says (EE) no modes. And it tried to enumerate different resolutions but reported: “test failed”. I ran out of ideas, I’m planning to reinstall a fresh Os and try again.
nvidia-bug-report2.log.gz (1.4 MB)

Your xorg.conf is wrong. Please delete it and use only and excactly the one I already gave you in my earlier post.

Yes, Thank you very much!

I just reinstalled ubuntu 20.10 and typed in the above config file example word by word. And now it indeed is working!

Sorry, I thought I understood your config and merged it with the existing one I had on a different machine.

I guess I didn’t really understand it.

Thank you so much for the help!