Fan not working

I bought the Noctua-NF-A4x20 PWM and run “sudo jetson_clocks”. After that I run “jetson_clocks --show” and it tells me “FAN: speed=255”. But the fan just keeps twisting a couple degrees every 5 seconds. That doesn’t change with high GPU temperature and the problem persists on for 2 fans and 2 nanos.

Hi manthey, are you using the Noctua NF-A4x20 5V PWM version of the fan? It is different than the NF-A4x20 PWM version, which uses 12V supply. The Nano supplies 5V.

Yes, thats correct. But I followed some link to Amazon which pointed me to that model. It’s really annoying how many hours I spent now running after hardware to work with the Nano.

With a standard Samsung fast charger 5V2A the Nano didnt even boot properly (10W Peak? Mode).
So I bought the 3A Micro USB psu.
That worked fine until I switched on the GPU.
so I had to buy a 5A5V Jackbarrel PSU
To figure out I needed to buy jumpers to use it.
After that I figured out the GPU gets up to 85C so I need a fan
I bought the fan which comes without screws
I bought the screws to figure out I bought the wrong fan
I try to mount the fan with M3 Screws but the mounts on the passive cooler dont fit
So tomorrow I send back the fans and bring back the screws
To order new screws and new fans.

Guys really. Take 120$ and give me a board I can work with.

Sorry about that Tobias - can you point me to where the link was to Amazon and the 12V version of the fan? Will try to get that corrected.

We have power supplies listed in this topic that are verified to work well, some users have posted others to there too. These are also listed in the Getting Started Guide and Jetson Nano Developer Kit User Guide. We are qualifying more power supplies to list in the future.

Hi Dusty,

I got the 5V fan, how do i start the fan ?

RESOLVED
ON :
sudo sh -c ‘echo 255 > /sys/devices/pwm-fan/target_pwm’

OFF :
sudo sh -c ‘echo 0 > /sys/devices/pwm-fan/target_pwm’
(slowly turned off)

“sudo jetson_clocks” does this among other things e.g. setting max performance. It has a command line option --show to display current settings. I recommend to use it.

Wonderfull have to launch a command line to have our fan to work…better & better…
BTW thank for the help ;)

Hi Mathey, have you solved the issue. I have the exactly same problem. Fan does not start running despide

sudo jetson_clocks

or

sudo sh -c 'echo 255 > /sys/devices/pwm-fan/target_pwm'

In order to start the fan I have to give it a spin with a finger.

For the reference:

  • I am using recommended Nocuta fan
  • Tried powering jetson with 5V 4A USB charger
  • Tried powering jetson with 5V 4A barrel charger

If it the fan with the wrong voltage it just twitches, but never spins. If it spins that sounds like a problem with the fan to me. Probably with the bearing.

Your fan is working fine now? I bought two Nocuta fans and both behaves same way.

Yes. You did not flip the connector?

No, what do you mean by flipping the connector?

I found out I bought 12V version of the fan. Will buy a 5V one, thanks for help.

mine works with

sudo jetson_clocks

but will never start without this line
doesnt matter how hot it reaches

any suggestions?