FDT creation failed! hanging... How to repair without reflashing?

Hi all,
I’ve tried to update to the last L4T this morning.
I’ve copied all my tx1 / on the rootfs dir and applied binaries on the PC.
After flashing, i’ve got this error:

Retrieving file: /boot/tegra210-jetson-tx1-p2597-2180-a01-devkit.dtb            
423986 bytes read in 253 ms (1.6 MiB/s)                                         
## Flattened Device Tree blob at 82000000                                       
   Booting using the fdt blob at 0x82000000                                     
   reserving fdt memory region: addr=80000000 size=20000                        
   Using Device Tree in place at 0000000082000000, end 000000008206a831         
Can't create DT prop nvidia,emc-burst-mc-regs to copy                           
Can't create DT prop nvidia,dvfs-version to copy                                
Can't create DT prop compatible to copy                                         
Can't create DT node emc-table@408000 to copy                                   
ERROR: board-specific fdt fixup failed: FDT_ERR_NOTFOUND                        
 - must RESET the board to recover.                                             
FDT creation failed! hanging...### ERROR ### Please RESET the board ###

My real problam is that i’ve installed many packages and don’t want to flash new stock l4t.


Direct file copy is rarely what you’d want to migrate a system. Many files are not “real” files, but instead files generated by the kernel (if you run “df -H -T” you’ll see some mount points are ext4, the rest are not…those others can be copied but should not…those are pseudo files in RAM generated by a kernel function). And then there is the issue of making sure permissions are unaltered.

One tool you have would be commands with the “don’t cross file systems” option, and running commands only from an ext4 partition. A better option is to clone the rootfs partition, and then do whatever you want to recover from the rootfs while it is loopback mounted.

A more subtle problem you may have run into is that only recently the initrd file became used (see “/boot/extlinux/extlinux.conf” for the initrd file name). If you do not name the initrd it won’t boot right, and if you copied extlinux.conf from a previous system, then that file won’t be named since earlier systems did not use this file. I would start by verifying you have the current extlinux.conf, and not the old one…and that the initrd file is where the extlinux.conf says it is.

Thanks for your help.

I’ve already backed up my root on rootfs before, for making a clone on sdcard which worked perfectly. This sdcard is actually used on another tx1 at work but i can’t access to it because i’m on holliday.
I think that the problem may come with the initrd.
I’ll try to make a stock l4t sdcard and see what’s wrong on the emmc.

If the extlinux.conf is the old one, then simply adding the INITRD line would possibly solve things.

Thanks for your help.
I’ve reflashed my rootfs with last l4t updates now. All work perfectly.