Fedora 21 Install Help Request


I’m trying to install the cuda toolkit 6.5 on Fedora 21. I want Fedora because it’s closest to RHEL as far as i know, which is where i want it eventually.

I downloaded the .run file, and have attempted to run it, but am met with errors on install and a concerning question at the start after the long EULA. I could not find the nvidia toolkit in the Software app for easy linux installation of programs. I am comfortable navigating, editing, etc in linux, but i have rarely ever installed things in the past. So i’m looking for help to figure out how to get it installed on the path i’ve been on, or if there’s an easier way to install the kit for fedora.

Here’s what i’ve done…

Download .run file, make executable, and try to run it.

Attempt 1. execute the .run file,

  • Prompt warning, attempting to install on “unsupported configuration”. Proceed? y.
  • yes to all samples, etc
  • Then as it starts to do the install: Fatal error - X server is running.
    Solution 1. go to “init 3” to not use the gui.

Attempt 2. execute the .run file from terminal, no gui at all. Fatal Error - ‘tried to disable nouveau, require restart’.

I haven’t solved this yet, but have made progress.

Progress 2.

  • Nouveau is an open source nvidia driver, makes sense i don’t want it.
  • I can “blacklist” nouveau, found on another linux forum
  • Blacklisting i still get a gui pop up on boot, and must do solution 1, but even then it fails
    and it knows that something is supposed to be disabling it, but it is still in effect.
    So i don’t know how to get past that. It failed quite similarly. I did “lsmod | grep nouveau” after a reboot to confirm it was gone per another forums suggestion after blacklisting it.

Here are my questions three:

  1. What is unsupported in my system? It doesn’t tell me what, just says it is.

I have:
GTX780, Intel i7-3770, ASUS P8Z77-V for hardware.
Fedora 21 and cuda download kit as of yesterday’s availability.

  1. Is there a way from a pure terminal to uninstall nouveau entirely and make it such that i boot to a terminal and then hopefully can cleanly install the toolkit (and start back up in gui/window form then on)?

  2. Is there an easier way to get the cuda toolkit installed on Fedora?

Thank you!

Start by reading the getting started guide:


  1. CUDA 6.5 doesn’t officially list Fedora 21 as a supported distro/version. (Read the above doc.) My suggestion is to use CUDA 7 RC instead, which you can get from developer.nvidia.com (you have to register, if you are not already a registered developer.)

  2. There are many methods to remove nouveau. You will need to switch to runlevel 3 to install the nvidia driver (i.e. switch to command line mode). So switch to runlevel 3 (init 3) first. After that, from a command line, as root, here is what I suggest:

echo -e "blacklist nouveau\noptions nouveau modeset=0"  > /etc/modprobe.d/disable-nouveau.conf
dracut --force

then reboot. At that point nouveau should be removed. (Now run the CUDA installer.) Blacklisting is not enough if nouveau is in the initrd image. The second line above removes that.

  1. I’ve had little trouble installing CUDA 6.5 on Fedora 20. I always use the runfile installer method (refer to the above linked document).

Thank you for the speedy response txbob. I will Try 1 & 2 first. I’d be okay with going back a version of Fedora, so i’ll go for the gold and keep that in my back pocket. The guide looks like it will be helpful for other info too. thx