Ffmpeg encode error

Hi, I am trying to use ffmpeg to encode, following the steps on:

I got ffmpeg build, however when I want to encode a video with it shows the following error:

#ffmpeg -i input.avi -c:v h264_nvenc output.mp4

[swscaler @ 0x55d34678d0] deprecated pixel format used, make sure you did set range correctly
[h264_nvenc @ 0x55d3405ca0] Cannot load libnvidia-encode.so.1
[h264_nvenc @ 0x55d3405ca0] The minimum required Nvidia driver for nvenc is 435.21 or newer
Error initializing output stream 0:0 – Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
Conversion failed!

It seems CUDA SDK is up to date:

# apt-get install cuda-toolkit-*
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘cuda-toolkit-10-0’ for glob ‘cuda-toolkit-*’
cuda-toolkit-10-0 is already the newest version (10.0.326-1).
0 upgraded, 0 newly installed, 0 to remove and 361 not upgraded.

Is there a older version of ffmpeg that supports h264_nvenc ?
Or how do I check or update the nvidia drivers ?

You may check this.

Hi, has been found a solution to this issue? I’m facing the same