ffmpeg_NVIDIA_gpu_acceleration.patch not compatible with current ffmpeg version

Hi there,

I’m trying to test ffmpeg with nvidea acceleration following the instructions here: http://developer.download.nvidia.com/compute/redist/ffmpeg/1511-patch/FFMPEG-with-NVIDIA-Acceleration-on-Ubuntu_UG_v01.pdf

I am working on an AWS g3.16xlarge running Ubuntu 18.

I have got to the point where I apply the ffmpeg_NVIDIA_gpu_acceleration.patch and finally got that to work having reverted my ffmpeg to commit to the one the patch was created against using

git checkout b83c849e8797fbb972ebd7f2919e0f085061f37f

But the problem now is that the ffmpeg configure fails with “error: ‘x264_bit_depth’ undeclared” presumably because my x264 version is too new for the older ffmpeg version.

I tried reverting x264 to an earlier commit (2451a728246) but it still doesn’t work.

Is there a newer version of the ffmpeg_NVIDIA_gpu_acceleration.patch which will work with the latest version of ffmpeg please?

Alternatively, could you please tell me which x264 version was used in your installation please?

Many thanks,

For the benefit of anyone else having this problem, I’ve got round it for now by reverting the x264 version using

git checkout fad44d59b3adeb29b9c92fde0b80116cde79020e

But that version is from 2015 so I would really like to be able to use the latest versions of both x264 and ffmpeg - could someone advise please?