File Load Error for my_model.pth ( Course: Getting Started with A.I. on the Jetson Nano )

After I save a model and remove it and then try to reload it, I get ( File Load Error my_model.pth )

I’ve tried different things, nothing has worked.

Any suggestions?

Thank you

Quick questions:

  1. For the course we suggest to use either of Chrome or Firefox browser. Please have a look at
    https://devtalk.nvidia.com/default/topic/1058929/jetson-nano/jupyterlab-on-nano-model-not-found/post/5369084/#5369084
  2. Can check the size of model ? if it is resnet-18 then it should be around 44MBs
  3. Are you uploading through JupyterLab ? or training on board?

Q3 confused me. I uploaded through jupyter lab, I’m assuming. Training headless via usb. Followed directions. Everything was great. Trained some models and saved them. When I went back to reopen one I got that message.

I’m using chrome. Firefox doesn’t take the password. Says I have invalid credentials.
I tried Microsoft browser and jupyter lab loaded, but I had the same problem when I tried to open one of my saved files with a trained model I had worked on.
Same thing happened to my regression models as well.

Are there other ways I can save my work?
Am I missing something when I save my model? It’s just naming it and pushing a button right? File shows up with name, just won’t open again.

Thank you for any help

…also model is under 44MBs