Flashing Jetson TK1 Fails: NvError 0x120002 bootloader download failed (bad data)

Hi all,

Recently I started having problems with one of my Jetson TK1’s where when I tried to boot it would get hung up with some I2C error messages. Eventually it would get into Ubuntu, but the mouse/keyboard wouldn’t work so i couldn’t really do anything. So I decided to reflash.

I’ve been hitting an error message when I try to reflash using JetPack. The error points to the log message, the last few lines of which are:

RCM communication completed
BCT sent successfully
sending file: tegra124-jetson_tk1-pm375-000-c00-00.dtb

- 59661/59661 bytes sent
tegra124-jetson_tk1-pm375-000-c00-00.dtb sent successfully
odm data: 0x6009c000
downloading bootloader -- load address: 0x83d88000 entry point: 0x83d88000
download command failed NvError 0x120002
command failure/warning: bootloader download failed (bad data)

Failed flashing ardbeg.

I have tried reflashing multiple times with different USB cables, different host machines (all running 14.04, and have successfully flashed TK1’s before), and even different version of Jetpack (started with 2.2, 3.0 also failed). All have given the same error message.

From other posts I’ve seen that this could be grounds for RMA but I would like to get some input to see if I can get it working, as I’m leaving to travel for work next week. Luckily I have a few TK1’s but this was my development machine so I’d like to have this working for the trip if possible.

I’m attaching the full log message in case it helps.
flash_os_tk1.log (105 KB)

It looks like USB was able to query the Jetson and download at least some initial data (“BCT sent successfully” and the device tree). After this USB fails with packet NAK (0x120002). Are any of these hosts a VM? This can change and VMs are unreliable for USB. If the hosts are native Linux and not VM then it is probably RMA time; if the hosts are VM you’re probably in luck and it would be a host issue.

Both my hosts are native Linux machines. Is there anything else I can try or should I go straight to RMA?

From the description and the fact that multiple computers have the issue I would go for RMA. There isn’t much more that you could do from your side and there is no VM to cause doubts.