Issues with Jetson TK1 Flashing

When I first got the Jetson, it did not show anything on the display, and apparently did not boot the OS. I tried reflashing with version 21.2 (, following the steps on the quick start guide, but the flashing fails and I get the following error message:

*** Flashing target device started. ***
./nvflash --bct PM375_Hynix_2GB_H5TC4G63AFR_RDA_924MHz.cfg --setbct --configfile flash.cfg --create --bl fastboot.bin --odmdata 0x6009C000 --go
Nvflash 4.13.0000 started
BR_CID: 0x34001001740cb1490000000015020580
rcm version 0X400001
Skipping BoardID read at miniloader level
System Information:
chip name: unknown
chip id: 0x40 major: 1 minor: 1
chip sku: 0x0
chip uid: 0x00000001740cb1490000000015020580
macrovision: disabled
hdcp: disabled
jtag: disabled
sbk burned: false
board id: 0
warranty fuse: 0
dk burned: false
boot device: emmc
operating mode: 3
device config strap: 0
device config fuse: 0
sdram config strap: 0

RCM communication completed
BCT sent successfully
sending file: tegra124-jetson_tk1-pm375-000-c00-00.dtb
[b]data send failed NvError 0x120002
sending dtbfile failed NvError 0x0
command failure/warning: bootloader download failed (bad data)
bootloader status: BCT is invalid or corrupted or SDRAM params may be wrong (code: 12) message: DownloadFile 1130 flags: 0

Failed flashing ardbeg.[/b]

I have tried many variation of the flash script, to no avail:

sudo ./ -S 14580MiB jetson-tk1 mmcblk0p1
sudo ./ -S 8GiB jetson-tk1 mmcblk0p1
sudo ./ jetson-tk1 mmcblk0p1
sudo ./ -S 14GiB jetson-tk1 mmcblk0p1
sudo ./ –L bootloader/ardbeg/u-boot.bin -S 8GiB jetson-tk1 mmcblk0p1
sudo ./ -S 8GiB jetson-tk1 –L bootloader/ardbeg/u-boot.bin mmcblk0p1

Any help regarding this isssue would be greatly appreciated.

Some addicional information of my host machine:

lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty

uname -a:
Linux hagen-lap 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

There are a lot of things which can go wrong for display over HDMI…far fewer things when viewing the serial console. Is serial console set up? Debugging probably requires at least some view of serial console.