Trouble Flashing a TK1 Pro

I have a couple of TK1 development boards I am trying to revive and I am stuck. I am running JetPack and tried both 2.2 and 3.1 versions, in dedicated Ubuntu 14.04 installs and in virtual boxes, and every time the install gets stuck:
*** Flashing target device started. ***
./nvflash --bct PM375_Hynix_2GB_H5TC4G63AFR_H5TC4G63CFR_RDA_924MHz.cfg --setbct --configfile flash.cfg --create --bl fastboot.bin --odmdata 0x6009C000 --go

I have left it for 24 hrs and it never finishes.

Boards are labeled P1860

I verified the USB port is seen by doing lsusb and see the nvidia device. I must be putting the boards into recovery mode correctly since the usb port is appearing.

I do see this error in _installer/logs/TK1/filesystem_tk1.log:
Extracting the kernel headers to /home/kevin/TK1/Linux_for_Tegra_tk1/rootfs/usr/src
tar: write error

Could this be it?

I am pretty stumped. Anyone have a clue for me?


Also I tried re-running the flash manually and it also seems to hang:

Nvflash 4.13.0000 started
BR_CID: 0x340010017420a1811c00000018000180
rcm version 0X400001

Skipping BoardID read at miniloader level
System Information:
chip name: unknown
chip id: 0x40 major: 1 minor: 1
chip sku: 0x0
chip uid: 0x000000017420a1811c00000018000180
macrovision: disabled
hdcp: disabled
jtag: disabled
sbk burned: false
board id: 0
warranty fuse: 0
dk burned: false
boot device: unknown
operating mode: 3
device config strap: 0
device config fuse: 0
sdram config strap: 0

RCM communication completed

Unsupported parameters
BCT sent successfully
sending file: tegra124-jetson_tk1-pm375-000-c00-00.dtb

and hangs…

I am not familiary with the pro version, but “tar: write error” would perhaps be a serious problem. Either the source of the tar file is missing (plausible if the flash program were told to download something which doesn’t exist, or the URL was incorrect), or else there is some file system or corruption issue on the host. If tar fails like this, then you can’t really be sure of much else being guaranteed so far as the host side files go.

I am curious, what do you get from this?

df -H -T /home/kevin/TK1/Linux_for_Tegra_tk1/rootfs/

Is your host a VM, or is anything at all unusual about it, e.g., using an external hard drive?

Thanks for the help!

I did:
df -H -T /home/kevin/TK1/Linux_for_Tegra_tk1/rootfs/
and it reported:
/dev/sda1 ext4 58G 23G 32G 43% /

I had re-run: manually which seemed to be the step that failed in the automatic setup and cause that tar error

There is no external hard drive on the VM or the bare-metal install of ubuntu i tried

Did you use “sudo” for unpacking the sample rootfs and for the step?

yes I did when I re-ran that step manually, and did not get the error that time.

Although the above could have resulted in things going wrong I doubt it would have resulted in “Unsupported parameters”. I am unsure of what command line would be used when flashing the “pro” version (perhaps the standard for a Jetson does not work on a Pro), but whoever does know the answer will probably need to know what the flash command was. Can you post the exact command you ran?

I didn’t run the command but the nvflash directly:

./nvflash --bct PM375_Hynix_2GB_H5TC4G63AFR_H5TC4G63CFR_RDA_924MHz.cfg --setbct --configfile flash.cfg --create --bl fastboot.bin --odmdata 0x6009C000 --go

copying from the command I see in the log files.

Hi kevin.lieberman,

The current JetPack was created for Jetson platform, it’s not compatible to use on TK1 Pro, you will need to contact with the team who provided the device to you to get the support.