Flashing Nano Devkit NVMe over USB fails

Hi @WayneWWW
Sorry , I am third person here in this topic. I too faced error.
I used same command what you you have mentioned.
But i got time out. Flash Logs attached . What would be reason. I am trying with default BSP.
Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for target to boot-up…
Waiting for target to boot-up…
Cleaning up…

cmd2FailWithTimeOut.txt (286.3 KB)

Please all dump the log from serial console when this flash error happend.

You provided the host side log already. I need the device side log to see what gets timeout.

@WayneWWW just a little hint. I am flashing the devices with WSL2 and had to increase the timeout in the flash script from the default 60 seconds.

It might be that a native environment also needs that value changed. The boards need quite some time to boot up and expose the ssh in some cases.

Hi @seeky15

Are we still talking about the issue “BL_CARVEOUT, error module: BL_CARVEOUT, reason: 0x03, aux_info: 0x00” in your uart log?

Actually I have some known flash issues in note and one of them is related to usb negotiation problem between host and Orin.

But I didn’t expect that issue has busyspin error in log. Based on the experience, that error will not have anything out from UART log.

Yes, the BL_CARVEOUT and the busyspin is the issue I face. But it only occurs when flashing with

-p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"

If you write that bootloader/t186ref/cfg/flash_t234_qspi.xml into your EMMC_CFG in the config file the board boots correctly.

There is already an error when creating the flash data on the host:

[   3.1736 ] MB1-BCT version: 0.10
[   3.1740 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_UNUSED5/ is not supported
[   3.1749 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_UNUSED5/ is not supported
[   3.1759 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_UNUSED5/ is not supported
[   3.1767 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_MCE_COVERAGE/ is not supported
[   3.1778 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_MCE_COVERAGE/ is not supported
[   3.1788 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_MCE_COVERAGE/ is not supported
[   3.1788 ] ERROR: /misc/tsc_controls/tsc_locking_config is not supported
[   3.1788 ] ERROR: /misc/tsc_controls/tsc_locking_diff_configuration is not supported
[   3.1788 ] ERROR: /misc/tsc_controls/tsc_locking_ref_frequency_configuration is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_locking_control is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_locking_adjust_configuration is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_locking_fast_adjust_configuration is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_locking_adjust_delta_control is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_capture_control_ptx is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_capture_config_ptx is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_stscrsr is not supported
[   3.1789 ] ERROR: /misc/tsc_controls/tsc_locking_adjust_num_control is not supported

If you have the busyspin error you will see it in the uart.
I have that after a successful flashing though. I had the timeout too, but that was only because the board needed longer than 60 seconds.


Ok. Please do not discuss about the delay in this topic anymore. I don’t think that is related to this topic. You can file another topic and share your delay patch in a new topic.

I only want to check the BL_CARVEOUT busyspin issue in this topic.

Could you share me below logs when you can access the board

  1. The host side log and uart log when you hit BL_CARVEOUT busyspin issue. Follow the document guidance step (directly copy and paste). Do not use anything else.
    Please be aware that I need clean default BSP in this step. I know you have a lot of customization. If you cannot make sure the BSP is clean, download a new BSP from sdkmanager or NV website.

  2. The “cat /etc/nv_boot_control.conf” result of your module

  3. The host side and device uart log when you applied your customization and make it able to flash.

Okay. I can do that, tuesday next week.
But be aware that anything I do for you here is something your people could do as well.


It looks like I didn’t make it precisely.
The reason I need to keep asking for your help here is because we cannot reproduce this on our side… We tried our module but it didn’t hit this issue.

I don’t know if that is due to some mistakes on our side or not. So want to confirm the module sku and info too.

Also want to know, is sdkmanager able to flash your orin nano devkit or not?

As you read from my posts above I am using WSL2. That is not supported from NVIDIAs side. Rumor has it that it cannot even be used to flash the boards. I had to modify the flash timeout. I am not sure if the SDK Manager is going to work in my setup.
You could question my use of WSL2, but I can assure you that I have not hit a single issue in 1 year which did not arise on a real Ubuntu host too.

What I will do is that I’ll install a fresh copy of L4T and use the sample rootfs to flash my board with exactly the command which did not work for me. Then we will see if the issue is with my board. I suspect so since the command which did not work with my Orin is working on a Xavier devkit (with modified variables of course).

Just to confirm again. This is a Orin Nano devkit + Orin nano module that hit an issue right?
Not xavier NX devkit carrier board + orin module.

Yes Orin Nano Devkit, with the module it was shipped with.

Tried the same command style which is used for the Nano Devkit afterwards with the Xavier Devkit and it worked.

is nvidia provided command working for you ?

“sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 jetson-orin-nano-devkit internal”

For me it works further than for you. You got another issue.
I suggest you make your own thread. You’ll need to post the log the flashing process and the serial log.


Hi @WayneWWW
Please need you your help for topic “Error at Orin Nano with NVMe Flash in NVMe and boot from NVMe

I have used same command but failure happen and attached host and Orin nano target logs


Just for your info. I just wasted 4 hours trying to figure out why the command you posted did not work at all.
The double quotes are wrong and lead to a flash failure.

Sorry for that. That is unavoidable one from forum text auto correction.
Actually, you don’t need to check my comment. Just use the one from document.


My command is just a copy & paste from it (sorry for forum auto correction again)

And I just want to know what is the log after you use the correct command. How is the status now?

Currently my device goes into busy spin when sending the boot blob with your command. Am flashing it correctly again and then will report back with your logs.

Errr… is “my command” means the one with typo or you are talking about the one directly copy from document…?