How to boot orin nano from Nvme

Hello team,

Any steps for making the orin nano to boot from nvme instead of SD card,

we had flashed image to nvme and powered on device , its stopping at bootloader level it seems,

prompt came,

UEFI Interactive Shell v2.2
UEFI v2.70 (EDK II, 0x00010000)
Mapping table
      FS1: Alias(s):F1:
      FS0: Alias(s):F0:
     BLK0: Alias(s):
Press ESC in 5 seconds to skip startup.nsh or any other key to continue.


any help on this for booting.

If this is rel-35 release, refer to

→ Jetson Orin Nano Developer Kit (NVMe) to flash your board.

If the issue persists even using above instructions, share us the full log and which SSD you are using.

Try other SSD too.

ours is 36.2.0 so we are following this Quick Start — NVIDIA Jetson Linux Developer Guide 1 documentation

we are transcend nvme 128GB,
nvme_bootlogs.txt (35.4 KB)

attached the logs for reference

Could you also test with rel-35.5 version too? Not sure if a bug in jetpack6.

which is the stable version? we are doing a product development with some custom carrier board, so that which u suggest us to go ahead and use, right now we are using 36.2.1.


Few questions here for me to better understand your situation

  1. Is there any NV developer kit on your side that can validate the same?

  2. Is your custom board using different PCIe controller as devkit? or you don’t know what I mean here?

From 35.5. also same issue, i have attached the logs for reference,
do u want us to change the boo
nvme_bootlogs_35_5.txt (37.0 KB)
tloader also from 35.5?

I want you to use the sdkmanager to flash the whole system to rel-35.5.

we have orin nabo developer kit, which uses SD card by default, but there one slot is there for nvme insert, we tried there also — seeing same issue.

one generel query: to boot from nvme do we have to configure somewhere to take image from nvme?

The only thing you need to try here are just below

→ Devkit with same NVMe + rel-35.5 (flashed with sdkmanager)

If this fails, It means this SSD has compatibility issue on Jetson. Try other kind of NVMe.

1 Like

we will try and let u know, no need of flashing 35.5 bootloader?

we will try with SDKmanager and let u know

Need to flash bootloader. Sdkmanager will do this work.

That is why I said just use sdkmanager.

1 Like

we will try it and let u know

Hello Wayne, we tried to flash NVMe from SDK manger, successfully flashed, but the booting is stuck at some place showing error for OTA folder

OTA work directory /mnt/ota_work is not found on /dev/nvme0n1p1

I have attached the logs for refernce, please help us on this,
nvme_half_bootlogs.txt (103.2 KB)


This log does not help.

Your current log stands for a case called “recovery boot”.

This situation would happen when your “previous” boot are all failed and in consecutive 3 times.

Thus, what we need to check is your previous failure log, but not this time.

Reflash your board again and immediately share me the log right after your flash. Do not wait for a while. Your waiting may just lead to another recovery boot.

Hi always, its attempting for Recovery Boot, even with SD card also.

how we can come out recovery mode?

Hi, we have modified the UEFI boot method to ‘Normal’ using this post

but after that again stuck at some place now in ‘Direct boot’ mode also
nvme_half_bootlogs_Db.txt (83.7 KB)

any suggestions here please.

Then are you able to mount this NVMe drive after connecting it to your host PC?
Are you sure SDK Manager did not throw any error?

No we have not got any error while flashing from SDK manager,

do you want us to check the logs during first boot?