Orin Nano does not boot or flash

Orin-Nano-Production-NVME-SDK_Manager_Log.txt (5.1 KB)
My Orin nano doesnt boot. I turn power on, Led turns on & fan starts, but it doesn’t get to display.

I am able to put it into force recovery with a jumper and see it on the host via USBC.

I tried to flash it via SDK Manager but it fails.
It errors on the line - “File rcm_state open failed”.

I also tried via initrd, and it failed saying cannot read board info.

Please let me know what can be done.

Could you share the command + full log when you run initrd command?

I ran the command from the Readme in ./tools/kernel_flash
for Orin Nano 8GB NVMe, with Board info, FAB, etc:

sudo BOARDID=3767 FAB=300 BOARDSKU=0003 BOARDREV=L.3 \

./tools/kernel_flash/l4t_initrd_flash.sh --no-flash jetson-orin-nano-devkit internal

please follow the quick start guide to run the correct command first.


A command with “–no-flash”, if you can read, then it indicates it won’t flash…

I do know how to read. I did follow basic instructions. For the sake of expediency shared the last command I had tried.
Please see attached logs for previous commands:

  1. Basic command
  2. External NVME command (though mine is a production board - so the nvme is internal - but i am unable to get it to show on the host via
    lsblk -d -p | grep nvme | cut -d\ -f 1

Here is my result for sudo blkid
/dev/sda: TYPE=“ext4”
/dev/sdb: UUID=“5ff1cf8b-bfe6-4048-9ee9-9f15719b0100” TYPE=“swap”
/dev/sdc: UUID=“fbea3a69-8c1d-4649-b0f2-e669185bf595” TYPE=“ext4”

and lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0955:7523 NVIDIA Corp. APX
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

02_external_NVME_command.txt (12.4 KB)

01_Basic_command.txt (11.3 KB)


This could be a known issue on ubuntu20.04 host. Please try other host ot flash the board.

Thank you for the prompt response.

I have tried 18.04 as well. Got the same error.

Would it work if I disconnect the nvme drive
and reformatted it (on host) and then reconnect?


I would suggest you could dump the uart log too.

If this is really the known issue as I said, then UART log would not dump any log.

However, if this is something else, then UART shall print.

BTW, did you flash any kind of jetson orin device before? I mean orin agx or orin nx.

Would it work if I disconnect the nvme drive
and reformatted it (on host) and then reconnect?

That depends on your result from UART log for now. But I guess it is not related.

Also, please attach both host side log and uart log when you test anything.

We need the full log to tell if they are really “same issues”. For example, actually I don’t think your issue on ubuntu 18.04 are same as what you got in ubuntu 20.04.


I have tried again from 18.05 host - x86 - via sdk manager and via initrd.

It fails at the same stage - failed to read board or fails at:
tegrarcm_v2 --instance 1-1 --new_session --chip 0x23 0 --uid --download bct_br br_bct_BR.bct --download mb1 mb1_t234_prod_aligned_sigheader.bin.encrypt --download psc_bl1 psc_bl1_t234_prod_aligned_sigheader.bin.encrypt --download bct_mb1 mb1_bct_MB1_sigheader.bct.encrypt
[ 0.0494 ] BR_CID: 0x80012344705DD51F1C0000000D028100
[ 0.0513 ] Sending bct_br
[ 0.0515 ] ERROR: might be timeout in USB write.

Please also find attached

Im awaiting UART cable - will share output of that. Is it possible the board has a problem? Should i send it back for checking?

flash-orin-nano-initrd-logs-18.04-original-cable.txt (195 KB)

SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_Orin_Nano_modules_2023-08-14_14-56-08.zip (288 KB)

SDKM_logs_JetPack_5.1.2_Linux_for_Jetson_Orin_Nano_modules_2023-08-14_15-17-50.zip (219 KB)

Hi @jaideepbir

I am not sure what is going one as I already mentioned in this comment.

Please read the document because your initrd flash command is always wrong…

I’m using the package downloaded from the site.

You can see that my command is

sudo BOARDID=3767 FAB=300 BOARDSKU=0003 BOARDREV=L.3 ./tools/kernel_flash/l4t_initrd_flash.sh jetson-orin-nano-devkit internal

But it converts that internally

Please suggest what the right command should be. It is my first attempt and I happened to buy a production board in this bundle.

Could you click into the document link and look into the commands (I already posted the document link 2 times…)

Jetson Orin Nano Developer Kit and Jetson Orin NX Developer Kit (NVMe)


Jetson Orin Nano Developer Kit and Jetson Orin NX Developer Kit (USB):


Jetson Orin Nano Developer Kit and Jetson Orin NX Developer Kit(SD):

Do you know that Orin Nano does not have internal disk so that you have to at least use one of the above 3 storage?

If you cannot see the document link, please share a screenshot of what you saw in previous comment.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.