Problems flashing Orin Nano to NVME

I am trying to flash a Orin Nano devkit with an NVMe. The host computer is running Ubuntu 18.04, and it is connected with a USB to the USB-C port of the board. The FC_REC pin is shorted to ground.

Sdkmanager can see the unit, but it never finishes flashing it, the first error is

ERROR: Flash Jetson Linux - flash: [ 0.0209 ] ERROR: failed to read rcm_state

The full logs are attached. (194.2 KB)

I have checked the board is correct [1]

$ lsusb
...
Bus 003 Device 030: ID 0955:7035 NVidia Corp. 
...
$ file ~/nvidia/nvidia_sdk/JetPack_5.1.3_Linux_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra/kernel/Image
/home/admin-it/nvidia/nvidia_sdk/JetPack_5.1.3_Linux_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra/kernel/Image: MS-DOS executable

The commands in [2] don’t work:

$ sudo echo 8 > /proc/sys/kernel/printk
-bash: /proc/sys/kernel/printk: Permission denied
$ sudo echo 'module usbcore +p' > /sys/kernel/debug/dynamic_debug/control
-bash: /sys/kernel/debug/dynamic_debug/control: Permission denied
$ sudo  echo 'module xhci_hcd +p' > /sys/kernel/debug/dynamic_debug/control
-bash: /sys/kernel/debug/dynamic_debug/control: Permission denied

I think the first time I tried, flashing to eMMC was an option, but now it isn’t anymore. The only choices are USB, NVMe, and SD card (although only the NVMe is actually plugged in).

Forum references
1
2

Hi david.mh,

There’s no eMMC on Orin Nano devkit.

It seems there are many errors showing in your log.
Could you try to use the following command to flash your board?

$ cd <nvidia_sdk>/JetPack_5.1.3_Linux_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra
$ sudo ADDITIONAL_DTB_OVERLAY_OPT="BootOrderNvme.dtbo" ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_t234_nvme.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" --showlogs --network usb0 jetson-orin-nano-devkit internal

Please share both flash log from host and serial console log from the device.

Here they are:

stdout.log (279.9 KB)
flash_3-1_0_20240516-091414.log (6.4 KB)

SSH ready
mount.nfs: Connection timed out
Flash failure
Cleaning up...

Both logs seem similar and are from host.
I want to check the serial console log output from your board.

Where are those?

These 2 logs are both from host rather than the serial console log from Jetson.

I have tried to flash again with a UART logger connected to the RX/TX headers, but there is no output at all. I am even connecting the TX pin to the oscilloscope, the trace is constant at 3.3V. What am I doing wrong?

When changing to the SD card, it boots, so the board isn’t broken.

For the Orin Nano devkit, you can refer to Jetson Nano & NX Style - Serial Debug Console - JetsonHacks to get the serial console log.