Flashing via SDKM Fails With RTNETLINK Errors

Attempting to flash to an nvme drive fails the same way every time. I have tried both the automatic setup after flashing the SD Card and the manual setup via recovery mode and both fail the same way.

OS: Ubuntu 20.04

Logs are attached, but the terminal is spammed with

INFO: Flash Jetson Linux - flash: RTNETLINK answers: Permission denied

Once I tried hard cycling the Orin when this happened and I got a different error message

INFO: Flash Jetson Linux - flash: RTNETLINK answers: File exists

This issue is specific to the Orin Nano; I tested on a Jetson Nano and it flashed fine.
SDKM_logs_JetPack_5.1.1_(rev._1)_Linux_for_Jetson_Orin_Nano_modules_2023-05-09_19-53-00.zip (259.5 KB)

Is your host able to flash any other kind of jetson orin before? Orin AGX or Orin NX.

The initrd flash command requires to run ssh or NFS server between your host and jetson. It seems not able to establish on your host.

I flashed a Jetson Nano last week with the same host; does the Jetson Nano use the same method of flashing? I can ssh into the Orin just fine, so I don’t think it’s an ssh issue. Is there a way to debug this any further? The error messages aren’t very helpful.

Yes, the error message is not helpful. Flash is two-side issue. You have the log from host now, but you don’t have the log from device side.

Generally you need to use this to dump device log from serial console.

And sorry that my previous comment was not precise. Jetson Nano result does not matter because the flash method is totally different. What I want to say is does this host ever use initrd flash tool on any orin series board before. (as Jetson nano does not support initrd flash, its result does not matter here)

Serial port log attached. It ended with this
cutecom.log (101.0 KB)

[08:35:19:687] [    7.880613] tegra-xudc 3550000.xudc: EP 0 (type: ctrl, dir: out) enabled␍␊
[08:35:19:694] bash: cannot set terminal process group (-1): Inappropriate ioctl for device␍␍␊
[08:35:19:701] bash: no job control in this shell␍␍␊
[08:35:19:705] bash-5.0# [    8.416909] mmc1: SDHCI controller on 3400000.sdhci [3400000.sdhci] using ADMA 64-bit␍␊
[08:35:20:191] [    8.473379] tegra-xudc 3550000.xudc: EP 5 (type: intr, dir: in) enabled␍␊
[08:35:20:197] [    8.473592] tegra-xudc 3550000.xudc: EP 3 (type: bulk, dir: in) enabled␍␊
[08:35:20:204] [    8.473798] tegra-xudc 3550000.xudc: EP 2 (type: bulk, dir: out) enabled␍␊
[08:35:20:213] [    8.474086] IPv6: ADDRCONF(NETDEV_CHANGE): rndis0: link becomes ready␍␊
[08:35:20:217] [    8.474227] tegra-xudc 3550000.xudc: EP 7 (type: bulk, dir: in) enabled␍␊
[08:35:20:224] [    8.474483] tegra-xudc 3550000.xudc: EP 4 (type: bulk, dir: out) enabled␍␊

And SDKM showed the same errors as my original post.

What is the result of “sysctl -a |grep ipv6” on your host?

A whole lot of information about my network connections. ipv6 is enabled, but I do have a VPN running that might be interfering. Let me try disabling that and flashing again.

Same failure even with the VPN disabled.

Still no resolution. I worked around it but it’s kind of ridiculous how broken this is considering how long Jetpack has been around.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.